Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3851 closed defect (fixed)

TOUCHE: Missing characters in the spanish version

Reported by: jvprat Owned by: cyxx
Priority: normal Component: Engine: Touche
Keywords: Cc:
Game: Touché: The Adventures of the Fifth Musketeer

Description

I've found a few talk lines in the spanish version of Touche that are missing some characters. For example, the text in the attached screenshot should read: ...¡¡¡FUERA DE AQUÍ Y NO VOLVÁIS!!! I tried to debug it and found that Í corresponds to 0xD6, and Á is 0xB5. It looks like the missing characters are always uppercase with accents. I don't know if it's a code bug or they're missing in the game font. If it was the second case, mapping those characters to the ones without accents should be enough.

I've tried it on both trunk and the 0.12.0 branch, with the same result.

Ticket imported from: #2040311. Ticket imported from: bugs/3851.

Attachments (2)

touche-es.jpg (86.5 KB ) - added by jvprat 12 years ago.
Screenshot
spa-charset.png (171.1 KB ) - added by cyxx 12 years ago.
spanish charset

Download all attachments as: .zip

Change History (10)

by jvprat, 12 years ago

Attachment: touche-es.jpg added

Screenshot

comment:1 by fingolfin, 12 years ago

Can you run it in DOSBox to test whether the issue is in the datafiles or in ScummVM? Thanks!

comment:2 by jvprat, 12 years ago

Got the same result with the original interpreter, so it may be a data issue.

comment:3 by cyxx, 12 years ago

Characters 0xD6 & 0xB5 are missing in the charset (see 0 entries in Graphics::_spaFontOffs). Mapping these to lowercase sounds good ; are there any other characters which should be fixed or only those 2 ?

comment:4 by jvprat, 12 years ago

So far I've just found those two missing characters (repeated in other sentences), but the potential missing characters are the uppercase counterparts of "áéíóú" and maybe also Ñ (I don't know what will be their values in the game). I'm surprised those characters are missing, since it looks like each version had its own font. Is there any hope those glyphs exist in the font but are mapped to other values? If remapping to known characters is the only solution I guess it would be better to use the accent-less uppercase instead of the lowercase with accent, since it isn't required to use accents in uppercase words.

by cyxx, 12 years ago

Attachment: spa-charset.png added

spanish charset

comment:5 by cyxx, 12 years ago

Here the complete spanish charset (which has been extracted from the original executable), accentued uppercase letters are missing. File Added: spa-charset.png

comment:6 by jvprat, 12 years ago

Great, thanks. Then this would be the desired mapping: Á (0xB5) -> A É (?) -> E Í (0xD6) -> I Ó (?) -> O Ú (?) -> U

comment:7 by cyxx, 12 years ago

should be fixed with svn 33690. I modified the spanish charset for 0xB5 & 0xD6. If you encounter other missing glyphs during playback, please report it here ; thanks !

comment:8 by cyxx, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.