Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#3826 closed defect (fixed)

SQ2: Prompt disappears when it shouldn't.

Reported by: SF/buddha_ Owned by: sev-
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: Space Quest 2

Description

In the very first room in Space Quest II (Where Roger is in a space suit outside cleaning the station) wait until the wrist watch gives a sound and Roger loses his broom. Then type "look at watch" to get a close up of the watch. At this point there's no prompt at all although in the original game there is a ">".

Tried the Amiga version 2.0F of Space Quest II using WinUAE to confirm that the ">" prompt is actually there in the original and isn't changed in any way when looking at the wrist watch. Tried the same Amiga version using ScummVM trunk revision 33258 and branch-0-12-0 revision 33258 and they both lose the prompt when first showing the wrist watch.

Using the 0.11.1 release of ScummVM the prompt isn't changed when looking at the wrist watch so this is a regression that has been introduced after it.

This regression may have been introduced when fixing these bugs:

- Bug #1939632: SQ2: Text prompt glitch.
http://sourceforge.net/tracker/index.php?func=detail&aid=1939632&group_id=37116&atid=418820

- Bug #1875076: AGI GR: Input prompt not changing in outhouse.
http://sourceforge.net/tracker/index.php?func=detail&aid=1875076&group_id=37116&atid=418820

I'd guess this bug would probably also occur with the PC version of Space Quest II but as I haven't tried it I am not certain whether it does. If someone else could test it, that'd be nice, as my PC version of Space Quest II is currently in another city than I am :-).

Ticket imported from: #2026570. Ticket imported from: bugs/3826.

Change History (3)

comment:1 by SF/counting_pine, 11 years ago

I've tested this on the PC version 2.0F, in ScummVM 0.13.0svn (Nov 16 2008 10:09:10) Win32 build.

The '>' prompt disappears on entering the Watch screen, and doesn't return until the user presses Enter, or F3, or opens and closes the Inventory screen, or exits to the airlock chamber.

The '_' cursor also disappears, but comes back when the user types.

Incidentally, the cursor is supposed to disappear during the sweeping cutscene (after the message about Roger "doing what he does best", up to the one about his watch beeping), but in ScummVM it remains onscreen all through that sequence. Not a big deal of course, but it might be helpful to know...

comment:2 by sev-, 10 years ago

Fixed in SVN.

comment:3 by sev-, 10 years ago

Owner: set to sev-
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.