Opened 11 years ago

Closed 11 years ago

#3642 closed defect (invalid)

SQ2: Stuck on the wall with plunger forever in space quest 2

Reported by: SF/nudgegoonies Owned by: SF/buddha_
Priority: normal Component: Engine: AGI
Keywords: original Cc:
Game: Space Quest 2

Description

I played SQ2 till the point in the station with the trap door. Use the saved game, go south to the next room. Go right until the wall appears, go left until the wall appears. Type "stick plunber to wall" but wait with pressing enter until the trapdoor is near you otherwise you can't hold the plunber so long and fall into the acid. The problem is, after hanging on the wall and the trap door closes the walls won't disappear as written in the solution in wich i looked becaus i thought there might be a solution but now i am sure this is a technical problem. I startet playing under a fresh installation of scummvm 0.11.0 and now updated to 0.11.1 to see if this helps but no luck. The game's version is 2.0f english from the spacequest collection. My OS is Windows98SE SP2.
Regards,
Andreas

Ticket imported from: #1905928. Ticket imported from: bugs/3642.

Attachments (1)

sq2.019 (1.3 KB) - added by SF/nudgegoonies 11 years ago.
Savegame before the problem appears.

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by SF/nudgegoonies

Attachment: sq2.019 added

Savegame before the problem appears.

comment:1 Changed 11 years ago by SF/nudgegoonies

Summary: Stuck on the wall with plunger foreverStuck on the wall with plunger forever in space quest 2

comment:2 Changed 11 years ago by SF/nudgegoonies

There is another thing. At the beginning you can enter a name and it is impossible to enter capitals. I named myself roger wilco instead of Roger Wilco. In the real game capitals work.

comment:3 Changed 11 years ago by sev-

Please, submit bug with capitals in the name separately.

comment:4 Changed 11 years ago by sev-

Owner: set to SF/buddha_
Summary: Stuck on the wall with plunger forever in space quest 2SQ2: Stuck on the wall with plunger forever in space quest 2

comment:5 Changed 11 years ago by bluegr

The problem with capital letters should be fixed in the latest unstable SVN version of ScummVM (currently 0.12.0), with some changes I made to the keyboard input code (commit #30356)

comment:6 Changed 11 years ago by SF/buddha_

Keywords: original added; script removed
Resolution: invalid
Status: newclosed

comment:7 Changed 11 years ago by SF/buddha_

This is not a bug.

You have to write "drop down" after the floor
has closed and you're still hanging onto the
plunger. Tried it with the original interpreter
under DOSBox 0.72 and it behaved the same way,
so this is how the game works.

Here's some debugging info if someone else than me
wants to try this using the original intepreter too:

Writing "backstage" enables debug mode in SQ2.
Then you can teleport to a new room using command "tp"
and get objects using command "get object".

plunger = object 28
arrival platform at vohaul's station = room 49
corridor with the acid = room 66

"stick plunger to wall" sticks the plunger to the wall and
"drop down" drops Roger back to the floor.

Note: See TracTickets for help on using tickets.