Opened 12 years ago

Closed 9 years ago

#3641 closed defect (wontfix)

DIG: text borders/shadows glitches (with 0.9.0 savegame)

Reported by: SF/glorifindel Owned by: sev-
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

I'm using the italian cd version of The Dig and ScummVM 0.11.0 under WinXP.
If you load the savegame attached (it's the location with the entrance of the tomb and a dead tree on the right side, but the bug afflicts all the locations) and try to look at any object, the black shadows of the bottom text turns to green and the subtitles black border disappears (see screenshot)
This savegame was made with ScummVM 0.9.0, if I start a new game no bugs occurs.

Ticket imported from: #1905032. Ticket imported from: bugs/3641.

Attachments (3)

dig.zip (35.5 KB ) - added by SF/glorifindel 12 years ago.
Savegame
scummvm00001.png (67.0 KB ) - added by SF/glorifindel 12 years ago.
Screeenshot
scummvm00003.png (42.0 KB ) - added by SF/glorifindel 11 years ago.
Correct bottom text / Missing subtitles shadows

Download all attachments as: .zip

Change History (15)

by SF/glorifindel, 12 years ago

Attachment: dig.zip added

Savegame

by SF/glorifindel, 12 years ago

Attachment: scummvm00001.png added

Screeenshot

comment:1 by SF/glorifindel, 12 years ago

File Added: scummvm00001.png

comment:2 by fingolfin, 12 years ago

Component: Engine: SCUMM
Game: The Dig
Summary: THE DIG: text borders/shadows glitches (with 0.9.0 savegame)DIG: text borders/shadows glitches (with 0.9.0 savegame)

comment:3 by SF/glorifindel, 11 years ago

This issue appears also in Full Throttle (italian) with 0.9.0 savegames and ScummVM 0.11.1 (Win32)

comment:4 by sev-, 11 years ago

Raising priority. This bug is nice to get fixed before the release.

comment:5 by sev-, 11 years ago

Priority: normalhigh

comment:6 by Kirben, 11 years ago

Does this problem still occur? I can't reproduce the problem in the English version of The Dig, when using the attached saved game or other old saved games (2004 - 2006) from the bug tracker.

comment:7 by SF/glorifindel, 11 years ago

Yes, this glitch still occur on latest 0.13pre version of ScummVM, but only on the subtitles: the bottom text shadows are now correctly black (screenshot attached).
File Added: scummvm00003.png

by SF/glorifindel, 11 years ago

Attachment: scummvm00003.png added

Correct bottom text / Missing subtitles shadows

comment:8 by SF/glorifindel, 11 years ago

Yes, this glitch still occur on latest 0.13pre version of ScummVM, but only on the subtitles: the bottom text shadows are now correctly black (screenshot attached).
File Added: scummvm00003.png

comment:9 by sev-, 10 years ago

perhaps this problem occurs only with this savegame?

comment:10 by SF/glorifindel, 10 years ago

I've just tried this bug with ScummVM version 1.00 RC and it always occurs with all my savegames.
If you want I can send them all.

comment:11 by sev-, 9 years ago

Owner: set to sev-
Resolution: wontfix
Status: newclosed

comment:12 by sev-, 9 years ago

I am closing this bug because it will be too much effort to fix it. At 0.9.0 we did not store required information in the savegames thus the glitch. A workaround is to leave the room and come back.

Note: See TracTickets for help on using tickets.