Opened 12 years ago

Closed 12 years ago

#3564 closed defect (fixed)

PSP: ITE shows " Error loading game resources"

Reported by: SF/das_brot Owned by: joostp
Priority: normal Component: Engine: SAGA
Keywords: Cc:
Game: Inherit the Earth

Description

ScummVM version: 0.11.0 (Jan 14 2008 22:11:27)
Game Language/Version: German CD
Platform: PSP

If i start ITE ScummVM shows a message with "Error loading game resources" but with the ScummVM Win Version the game run without problems.

I have the same problem with the German Version of IHNM.

ITE MD5´s

90252f09216de28bbffe80452b1aad95 *SOUNDS.RSC
5bd6c43dbb4afff1cde540660f929472 *VOICES.RSC
daeadae59f9216ee89153cb8114b80d8 *ITE.RSC
5b4c047a22e8dc960eef5d091f931505 *SCRIPTS.RSC

Ticket imported from: #1873637. Ticket imported from: bugs/3564.

Change History (13)

comment:1 Changed 12 years ago by bluegr

This can't be right, as already mentioned in the same forum post that you made about the unknown IHNM version. the MD5s of these files are not in the detector, so it's not possible that this version gets detected at all. Where did you obtain this version from?

How were the MD5s for these files calculated? From ScummVM itself or an external application?

Note that the most probable cause that it can't find the game's resources is the lack of implementation of the common File::exists() function in the PSP port

For reference, the relevant forum post is here:
http://forums.scummvm.org/viewtopic.php?t=5062

comment:2 Changed 12 years ago by SF/das_brot

I´ve used "Toast442.org MD5 GUI" and then md5deep to make the MD5´s with the same result

comment:3 Changed 12 years ago by sev-

Full MD5s are useless to us. ScummVM counts only first 5000 bytes for ITE.

Can you try it with desktop version of ScummVM?

comment:4 Changed 12 years ago by bluegr

This bug should be fixed now with joostp's commit #30537, can you check with the latest 0.12.0 SVN?

As sev mentioned, full MD5s are useless to us

The only way I've managed to make a correct MD5 check of a file chunk under Windows (by using one tool only) is with md5deep:
http://md5deep.sourceforge.net/

Download it and run it like this:
md5deep -p 5000 14.ald | find /i "offset 0-5000"

(Note that 5000 differs for each engine, it's 5000 for SAGA)

comment:5 Changed 12 years ago by SF/das_brot

Okay here are the new MD5´s
869fc23c8f38f575979ec67152914fee E:\ScummVM\ITE\ITE.RSC offset 0-5000
e2ccb61c325d6d1ead3be0e731fe29fe E:\ScummVM\ITE\SOUNDS.RSC offset 0-5000
2fbad5d10b9b60a3415dc4aebbb11718 E:\ScummVM\ITE\VOICES.RSC offset 0-5000
a891405405edefc69c9d6c420c868b84 E:\ScummVM\ITE\SCRIPTS.RSC offset 0-5000

comment:6 Changed 12 years ago by SF/das_brot

And ITE works with the latest 0.12.0 SVN

comment:7 Changed 12 years ago by bluegr

Good to know that ITE works with the latest SVN :)

The problem was indeed the lack of the File::exists() function in PSP, joostp implemented this now

This bug has been resolved for PSP, but I'll leave it open for now, till File::exists is implemented in all (or most of) the platforms that ScummVM runs under.

Currently, File::exists() is not implemented for the following ports (and thus, SAGA games don't work under those ports):
DC
DS
GP32
MorphOS
PalmOS
PS2
Symbian

comment:8 Changed 12 years ago by bluegr

Owner: set to bluegr

comment:9 Changed 12 years ago by sev-

thebluegr, I would suggest to open separate bugs for each platform and assign them to appropriate devs. This will let you make sure that it is fixed on all platforms and will draw attention of those porters.

comment:10 Changed 12 years ago by SF/das_brot

First thank you for the support and help :-)

But i have still the same problem with INHM here are the MD5´s

0439083e3dfdc51b486071d45872ae52 E:\ScummVM\INHM\MUSICFM.RES offset 0-5000
80f875a1fb384160d1f4b27166eef583 E:\ScummVM\INHM\MUSICGM.RES offset 0-5000
c92370d400e6f2a3fc411c3729d09224 E:\ScummVM\INHM\SCREAM.RES offset 0-5000
32aa01a89937520fe0ea513950117292 E:\ScummVM\INHM\SCRIPTS.RES offset 0-5000
1c610d543f32ec8b525e3f652536f269 E:\ScummVM\INHM\SFX.RES offset 0-5000
424971e1e2373187c3f5734fe36071a2 E:\ScummVM\INHM\VOICES1.RES offset 0-5000
c270e0980782af43641a86e4a14e2a32 E:\ScummVM\INHM\VOICES2.RES offset 0-5000
49e42befea883fd101ec3d0f5d0647b9 E:\ScummVM\INHM\VOICES3.RES offset 0-5000
c477443c52a0aa56e686ebd8d051e4ab E:\ScummVM\INHM\VOICES5.RES offset 0-5000
2b9aea838f74b4eecfb29a8f205a2bd4 E:\ScummVM\INHM\VOICES6.RES offset 0-5000
8b09a196a52627cacb4eab13bfe0b2c3 E:\ScummVM\INHM\VOICESS.RES offset 0-5000

comment:11 Changed 12 years ago by SF/das_brot

In i have the German Version from INHM

comment:12 Changed 12 years ago by bluegr

Owner: changed from bluegr to joostp
Resolution: fixed
Status: newclosed

comment:13 Changed 12 years ago by bluegr

For IHNM, you also need patches.re_ to get it working

Closing this (and assigning it to joostp, as he is the one who fixed it), I'll make separate bug reports as suggested

Note: See TracTickets for help on using tickets.