Opened 12 years ago

Closed 4 years ago

Last modified 4 years ago

#3563 closed defect (fixed)

AGI: The 13th Disciple: Game freezes in Dean's office

Reported by: SF/metafox Owned by: m-kiewitz
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: AGI Fanmade

Description

The game brings you up to the dean and stops you there. You can not move. When you talk to the Dean, the game freezes. Tested with 0.12.0 SVN (January 16, 2008) on Win32.

I have included a savegame at that point. Type "talk to dean" and it will freeze.

Ticket imported from: #1873361. Ticket imported from: bugs/3563.

Attachments (1)

agi-fanmade-2.000 (970 bytes ) - added by SF/metafox 12 years ago.
Right before game freeze

Download all attachments as: .zip

Change History (14)

by SF/metafox, 12 years ago

Attachment: agi-fanmade-2.000 added

Right before game freeze

comment:1 by fingolfin, 12 years ago

Summary: The 13th Disciple: Game freezes in Dean's officeAGI: The 13th Disciple: Game freezes in Dean's office

comment:2 by SF/buddha_, 12 years ago

Using the provided savegame (agi-fanmade-2.000)
things seem already broken as the parser doesn't
understand "talk to dean" at all. If I played from
the beginning of the game to the same point and
talked to the dean, it worked. But with the savegame
it doesn't.

So it seems saving or loading somehow breaks this game.

I tried a simplification of the problem.
Just started the game and saved the game in the
first room after the intro (The hallway outside
the Dean's office). If I try e.g. "look" after
saving it doesn't get recognized by the parser
anymore. Same happens if I restore the game and
try "look". Restarting fixes things but it gets
you only to the beginning of the game.

Tried the game with the AGI executable that came
with it under DOSBox 0.72 and it didn't even show
the intro as it gave an out of memory error.

Tried the game under NAGI 2.06 and with it the
saving & loading of games does seem to work ok.

As a sidenote I also noticed that in NAGI the ego
stopped right at the entrance of the Dean's office
(After just entering the Dean's office, that is)
but in ScummVM ego walked right up to Dean's desk.

comment:3 by sev-, 11 years ago

Apparently it is a broken savegame. Closing.

comment:4 by sev-, 11 years ago

Owner: set to sev-
Resolution: invalid

comment:5 by sev-, 11 years ago

Status: newclosed

comment:6 by SF/metafox, 6 years ago

Sorry for posting in a closed bug report, but it seems the closure was a bit premature (and I didn't want to open a duplicate report).

Playing this again, I have a better idea what happens (it's not actually a broken save game, but a problem with the way the engine handles the automatic movement of the characters).

When you enter the Dean's office, if you let ScummVM handle the ego's movement as per the script, one of two things happen. Either the ego goes straight up to the desk, or goes northeast straight into the Dean (as what happened when I first played the game). Both of these movements are incorrect, as it will cause the game to hang at different times.

If the ego goes straight into the Dean, the game will hang immediately, as happened in the first save game I posted. When this happens, the script will not continue, as the Dean can not walk with the ego directly in front of him. This causes the problem that happened when I first posted this, where the game hangs completely, and it's impossible to continue even by typing "talk to Dean".

If the ego goes straight into the desk, you can talk to the Dean, answer yes to his questions, however the game will hang when the script tells the ego to walk in front of the Dean, since the Dean is blocking the ego's movement. From here, you can only type yes to get the Dean to repeat his speech about giving him the hall pass. The game is not possible to continue, however, since it's impossible to move the ego on your own since movement here is controlled by the scripts.

However, you can get around this problem by typing "talk to Dean" immediately after you enter the office. This causes the ego to walk northeast into the wall, making it possible for the scripts to let the ego walk in front of the Dean. However, this only works in the instance that ScummVM has the ego walk to the northeast. If it walks north, the ego still gets stuck at the desk, and the game hangs.

comment:7 by wjp, 6 years ago

Since this is an old report, with which version of scummvm did you do your most recent experiments?

comment:8 by wjp, 6 years ago

Resolution: invalid
Status: closednew

comment:9 by SF/metafox, 6 years ago

I've upgraded to a new git version since I posted yesterday, but I've just played it again and can confirm that it still happens in 1.7.0git1464-g28b6078 Windows 32-bit.

comment:10 by m-kiewitz, 4 years ago

Keywords: script removed
Owner: changed from sev- to m-kiewitz

comment:11 by m-kiewitz, 4 years ago

I just figured out what went wrong. We did copying between VM Var 6 and the ego screen object the wrong way. I fixed this now in my current AGI graphics rewrite pull request and it works for me. Should hopefully get accepted soon.

Marking for later.

comment:12 by m-kiewitz, 4 years ago

Resolution: fixed
Status: newclosed

comment:13 by m-kiewitz, 4 years ago

This is now fixed by commit 428df3e6cb1e3d37c6b596ecd7049c1430905667

Note: See TracTickets for help on using tickets.