Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3553 closed defect (fixed)

LURE: Skorl in Selena\'s castle can be at 2 places

Reported by: bluegr Owned by: dreammaster
Priority: normal Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

In Selena's castle, I've told the boy to tell the Skorl to come down. I've hidden behind a column to the back, and let the Skorl drink and go to sleep. However, when entering the dining room, the Skorl is there again, beating our hero to a pulp :/

To reproduce, load the save game. You'll be in the cellar with the Skorl sleeping. Exit the cellar from the right of the screen, then exit the kitchen to the right and enter the dining room. You'll see the Skorl again and lose the game.

Playing the English version of the game using the latest SVN version of ScummVM under Windows XP SP2 and Windows Vista

Ticket imported from: #1866784. Ticket imported from: bugs/3553.

Attachments (1)

lure.002 (10.4 KB) - added by bluegr 12 years ago.
Glitch with the Skorl in the cellar

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by bluegr

Attachment: lure.002 added

Glitch with the Skorl in the cellar

comment:1 Changed 12 years ago by bluegr

As a follow-up: If I go upstairs, I can see the Skorl leaving the dining room. If I enter the room then, the game crashes with the following error: "Unhandled exception at 0x00878841 in scummvm.exe: 0xC0000005: Access violation reading location 0x02de7000".

Here's the stack trace:

> scummvm.exe!READ_LE_UINT16(const void * ptr=0x02de7000) Line 159 + 0x3 bytes C++
scummvm.exe!Lure::Hotspot::showMessage(unsigned short messageId=0, unsigned short destCharacterId=30011) Line 769 + 0xc bytes C++
scummvm.exe!Lure::Hotspot::actionPrecheck(Lure::HotspotData * hotspot=0x01881310) Line 945 C++
scummvm.exe!Lure::Hotspot::doOperate(Lure::HotspotData * hotspot=0x01881310) Line 1362 + 0xc bytes C++
scummvm.exe!Lure::Hotspot::doAction(Lure::Action action=OPERATE, Lure::HotspotData * hotspot=0x01881310) Line 1299 + 0x15 bytes C++
scummvm.exe!Lure::Hotspot::doAction() Line 1237 C++
scummvm.exe!Lure::HotspotTickHandlers::standardCharacterAnimHandler(Lure::Hotspot & h={...}) Line 2564 C++
scummvm.exe!Lure::HotspotTickHandlers::jailorAnimHandler(Lure::Hotspot & h={...}) Line 3113 + 0x9 bytes C++
scummvm.exe!Lure::Hotspot::tick() Line 476 + 0xe bytes C++
scummvm.exe!Lure::Game::tick() Line 90 C++
scummvm.exe!Lure::Game::nextFrame() Line 123 C++
scummvm.exe!Lure::Game::execute() Line 171 C++
scummvm.exe!Lure::LureEngine::go() Line 149 C++

comment:2 Changed 12 years ago by dreammaster

Owner: set to dreammaster
Summary: LURE: Skorl in Selena's castle can be at 2 placesLURE: Skorl in Selena\'s castle can be at 2 places

comment:3 Changed 12 years ago by dreammaster

Fixed - but you'll need to restore to an earlier savegame.. the problem was that the Skorl was getting 'activated' multiple times. With this fix, after he's activated the first time (when Minnow talks to him), his trigger will be properly deactivated so he won't appear again the next time you enter the room.

comment:4 Changed 12 years ago by dreammaster

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.