Opened 12 years ago

Closed 12 years ago

#3554 closed defect (fixed)

LURE: Actors can get stuck

Reported by: bluegr Owned by: dreammaster
Priority: normal Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

This is a weird one, I am not sure if it's a bug with the original game scripts or not.

Sometimes, actors seem to get stuck and they can't move at all. I'm attaching a save game where the 2 monks, Whelk and Gwyn, got stuck and just lie there motionless.

Playing the English version of the game using the latest SVN version

Ticket imported from: #1867643. Ticket imported from: bugs/3554.

Attachments (1)

lure.005 (11.6 KB) - added by bluegr 12 years ago.
Monks got stuck

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by bluegr

Attachment: lure.005 added

Monks got stuck

comment:1 Changed 12 years ago by fingolfin

Owner: set to dreammaster

comment:2 Changed 12 years ago by dreammaster

Component: Engine: Lure
Game: Lure of the Temptress

comment:3 Changed 12 years ago by dreammaster

Thanks for the savegame, but at that point it's too late - this is, ironically, the one bug I'd known about before the public testing. The issue is, as far as I've been able to track it so far, that the blocked movement handling code is meant to move the character to a random position and then resume whatever the NPC was doing before. However, in some circumstances, it seems it accidentally clears the schedule for the NPC instead.

comment:4 Changed 12 years ago by dreammaster

Resolution: fixed
Status: newclosed

comment:5 Changed 12 years ago by dreammaster

Forgot to close this - prior fix in HotspotTickHandlers::npcRoomChange should resolve this. Note that this will only prevent it occurring for actors who aren't already motionless (lost their schedule).

Note: See TracTickets for help on using tickets.