Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3552 closed defect (fixed)

LURE: Assertion when exiting from the dragon cave

Reported by: bluegr Owned by: dreammaster
Priority: normal Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

After talking to the dragon, when exiting the cave to meet Goewin again, an assertion is thrown when the player enters the room where Goewin is. The assertion is in hotspots.h, line 364 (frameNum < _numFrames).

To reproduce, load the saved game, exit to the right, then go right again, pull the left skull and enter the room to the right, and you'll encounter the assertion.

Playing the English version of the game using the latest SVN version of ScummVM

Ticket imported from: #1866782. Ticket imported from: bugs/3552.

Attachments (2)

lure.010 (10.1 KB ) - added by bluegr 12 years ago.
lure.007 (11.6 KB ) - added by bluegr 12 years ago.
Save just before entering the cave

Download all attachments as: .zip

Change History (8)

by bluegr, 12 years ago

Attachment: lure.010 added

comment:1 by bluegr, 12 years ago

Summary: Assertion when exiting from the dragon caveLURE: Assertion when exiting from the dragon cave

comment:2 by dreammaster, 12 years ago

Owner: set to dreammaster

comment:3 by dreammaster, 12 years ago

The problem was due the Blacksmith Luthern being reactivated when you enter this room (all village NPCs are reactivated at this point) - in the saved state from when you entered the cave, he was in a conflicting state - his current animation was for hammering on the anvil, but having been deactivated, reactivating him set him back to standard movement, which was incompatible with the current animation.

The blacksmith seems to be the only NPC that can be affected in this way, so I've committed a workaround fix which should fix the problem, but it takes affect when the blacksmith is deactivated when you initially enter the cave. Ideally I need a savegame from before you enter the cave to test that it works correctly. Could I prevail on you to upload an earlier save, please?

by bluegr, 12 years ago

Attachment: lure.007 added

Save just before entering the cave

comment:4 by bluegr, 12 years ago

Certainly, here's a save game just before entering the cave, with Goewin just outside the door and ready to open it :)
File Added: lure.007

comment:5 by dreammaster, 12 years ago

Everything looks good - I manually changed the animation Id, and verified that it was properly reset, so there shouldn't be any further problem.

comment:6 by dreammaster, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.