Opened 12 years ago

Closed 12 years ago

#3496 closed defect (fixed)

LURE: String compilation

Reported by: raziel- Owned by: dreammaster
Priority: normal Component: Engine: Lure
Keywords: script Cc:
Game: Lure of the Temptress

Description

ScummVM 0.11.0svn (Dec 8 2007 11:45:13)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

Here are a few (maybe connected) string errors i came
across. If you need me to file single reports on some,
please let me know.

1. Whenever Diermont "Ask"s someone if he/she got
something, Diermonts line starts with an "a", e.g.
"aRatpouch, do you have a Broken Glass"
"aWhelk, do you have a Book"
regardless of what NPC it is.

2. If Diermont asks Catriona (The Forge) if she got
"Cowbane" the sentence is build to
"Ask Catriona about Catriona" onstead of Cowbane
(wrong verb picked)

3. Ratpouch handles the gender of some NPC's wrong
(although, maybe he knows something we don't? ;-))
o Whelk (fatty monk) is referred to "Sorry, madam"
o Gwyn (old lady) is referred to "Sorry, sir"
by Ratpouch if he rans into them (maybe more?)

Lure of the Temptress (English/DOS)

AmigaOS4
gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1847812. Ticket imported from: bugs/3496.

Change History (4)

comment:1 by dreammaster, 12 years ago

I'll have a look at them. Although, from memory, the "Sorry madam" for the monks is in fact correct from the original game - it's the old joke of saying that someone wearing a robe is in fact wearing a dress :)

comment:2 by dreammaster, 12 years ago

Owner: set to dreammaster

comment:3 by dreammaster, 12 years ago

Resolution: fixed
Status: newclosed

comment:4 by dreammaster, 12 years ago

Points 1 and 2 fixed. For point 3, I was able to verify that the "Excuse me Madam" was correct; I wasn't able to get Ratpouch to bump into Gwyn, but I fudged the appropriate variables and confirmed that Ratpouch would say "Excuse me Sir" to her.

I can understand 'Excuse Me Madam' as a joke on the robes, but the 'Excuse Me Sir' seems a bit weird. Maybe they got the gender messages reversed in the script, although the bumped message for at least the Blacksmith is correctly 'Excuse Me Sir'.

I suppose it could be argued as being Ratpouch joking about how old Gwyn is. Since it's that way in the original game, I'm going to give them the benefit of the doubt, and leave it as is.

Note: See TracTickets for help on using tickets.