Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3495 closed defect (fixed)

LURE: pathfinding compilation

Reported by: raziel- Owned by: dreammaster
Priority: normal Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

ScummVM 0.11.0svn (Dec 8 2007 11:45:13)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

They are most surely connected to each other as the
way they appear and one can reproduce is always the
same. Here goes:

Similarities:
o Only when entered a room (place) from north or south
(does not happen when entered from west or east)
o Only if Diermont is still at the place he entered
(wasn't moved by the player or an NPC entering)

These actions:
1. "Look"ing at the notice on the door of "Severed Arms"
2. "Look"ing at the "Stall" thingies on the tables on
Marketplace
3. "Look"ing at the notice on the barred door on Town
Square (where Grub is)

make Diermont leave north instead of performing the
action (reading the notice/looking at the Stall)
whereas when entered from south he first goes all the
way past the notice/stall to leave. He does NOT leave
south.

Lure of the Temptress (English/DOS)

AmigaOS4
gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1847805. Ticket imported from: bugs/3495.

Change History (5)

comment:1 by dreammaster, 12 years ago

Owner: set to dreammaster

comment:2 by sev-, 12 years ago

And what does happen then? It crashes?

comment:3 by raziel-, 12 years ago

@sev

>And what does happen then? It crashes?

No, no crash, Diermont just doesn't perform the action he
is ordered to (and i HATE insubordination) :-)

It's compareable with the behaviour (bug) in the SAGA engine
(IHNM) where Ellen is in the monitor room. Clicking on the
rightmost monitor lets her walk out north of the room instead
of looking at the monitor (i thought i saw this bug on the
wiki, but it seems i dreamed it)

It's not related of course, just to give you an idea of the
behaviour Diermont is showing

comment:4 by dreammaster, 12 years ago

I've identified that if the mouse cursor position when a room is entered was already over a hotspot, clicking on that hotspot will cause the player to walk to an exit rather than that hotspot. This is likely the cause for the problems you described.

comment:5 by dreammaster, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.