Opened 12 years ago

Closed 12 years ago

#3468 closed defect (fixed)

LURE: Crash in 0.11.0 SVN

Reported by: SF/the_joe Owned by: dreammaster
Priority: normal Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

If you Operate the Rack that the Serf is tied down in, ScummVM crashes.

Thia is the latest SVN.

Ticket imported from: #1841818. Ticket imported from: bugs/3468.

Change History (12)

comment:1 by sev-, 12 years ago

Please, attach the save.

comment:2 by dreammaster, 12 years ago

Also remember to include the details of which language you are playing, and what system you're running it on.

comment:3 by dreammaster, 12 years ago

I'm going to presume that you were playing the German version, since I discovered that many of it's animation offsets were wrong in the data extract tool. I've committed a corrected lure.dat, so you'll need to grab a fresh copy to resolve the issue.

comment:4 by dreammaster, 12 years ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

comment:5 by SF/the_joe, 12 years ago

Oh sorry, it's the English version on Win32, yeah sorry I was in a rush.

I didn't provide a save because it's so near the beginning, I assumed it didn't matter. Also because it did crash, I couldn't save.

comment:6 by dreammaster, 12 years ago

Resolution: fixedworksforme
Status: closednew

comment:7 by dreammaster, 12 years ago

Alright, this is being reopened again - I tried several times with the English version, but I haven't been able to get it to crash. What error message, if any, did it give you?

If you can get it to happen repeatably, try making a savegame in the room before you do the action and posting it. Also, from a fresh game try opening the Debugger with Ctrl-D and typing 'enter 4' to jump directly to that room - see if it crashes that way as well.

As a final resort, try getting the lastest copy of lure.dat and see if it makes any difference.

comment:8 by SF/the_joe, 12 years ago

No error message, simply crashed. I'll get the very latest SVN and try it again.

comment:9 by SF/the_joe, 12 years ago

Yes I've definately suffered the crash. Ratpouch screams that he likes being small and inadequate then clicking on the dialouge box to close it, the game crashes.

comment:10 by sev-, 12 years ago

No way. You just most probably do not see the message. Please, read our FAQ at http://www.scummvm.org/faq.php#id2551089 to learn how to see the message and provide that.

comment:11 by dreammaster, 12 years ago

Resolution: worksformefixed
Status: newclosed

comment:12 by dreammaster, 12 years ago

I discovered what was likely the cause for your crash - the game previously allowed you to interrupt an active animation sequence (such as the player operating the rack), which would cause a crash when the game tried to set the frame to a movement frame that wasn't available at the time. The newest version fixes this, but you should test your older version to see whether this was the reason for your crash.

Note: See TracTickets for help on using tickets.