Opened 17 years ago

Closed 16 years ago

Last modified 13 years ago

#342 closed defect (fixed)

SIMON1TALKIE: Voice dialogs overlap quite often

Reported by: SF/madshi Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

Newest daily build, win32, simon1win talkie.

When having extensive dialog scenes, the dialogs quite
often overlap. E.g. when talking to the 4 magicians.
Sometimes Simon even talks to sentences at the same
time. But sometimes the dialogs are fully ok.

Ticket imported from: #580972. Ticket imported from: bugs/342.

Attachments (2)

SAVE.001 (3.0 KB ) - added by SF/madshi 17 years ago.
Simon meeting the magicians
SAVE.002 (3.0 KB ) - added by SF/madshi 17 years ago.
Simon meeting the barbarian

Download all attachments as: .zip

Change History (32)

comment:1 by eriktorbjorn, 17 years ago

I assume this is the same problem I see in the Simon1 demo,
where a message that should come out as four lines comes out
as two lines of garbled characters.

That problem seems to be that SimonState::talk_with_text()
doesn't break the text correctly. It's supposed to look
something like like this:

Some sort of magical
barrier located just
off screen is
stopping me.

But instead the text it tries to output is

Some sort of magical barrier located just
off screen is stopping me.

So it seems that the function has inserted the spaces to
center the lines, but not the newline characters.

I still haven't figured out exactly how this function is
supposed to work. It looks needlessly complicated, but
surely there has to be a reason for that...?

comment:2 by fingolfin, 17 years ago

eriktorbjorn made a patch, which is no in CVS. Mathias, can
you please try with latest CVS (or wait 24 hours and use the
nightly build), to see if the bug is gone now?

comment:3 by fingolfin, 17 years ago

Owner: set to fingolfin

comment:4 by SF/madshi, 17 years ago

I'll try with the next build, thanx for the great work, guys!! :-)

by SF/madshi, 17 years ago

Attachment: SAVE.001 added

Simon meeting the magicians

comment:5 by SF/madshi, 17 years ago

I'm sorry to say, but the bug is still there. Let me attach 2
save games. The first one is Simon meeting the 4 magicians.
Just talk to them. Simon will say something like "Listen to
me for a moment", one magician will say "Yes, boy.". But
those 2 sentences already overlap. The second savegame is
Simon meeting the barbarian. After the fragment is removed
from the foot of the barbarian, the dialog overlaps extremely
bad. Just try it out.

Thank you!!

P.S: Forgot to say, it's the german version, hope it makes no
difference...

by SF/madshi, 17 years ago

Attachment: SAVE.002 added

Simon meeting the barbarian

comment:6 by eriktorbjorn, 17 years ago

I'm starting to think we're talking of different bugs after
all. Do you mean that there are several different messages
on screen at the same time, and that these are overlapping
each other?

The problem I had - and possibly fixed - was where lines
from the same message were overlapping.

Unfortunately the version of Simon the Sorcerer that I
bought doesn't seem to have subtitles at all, so even if I
knew how this code worked - which I don't - I wouldn't be
able to test this. :-(

comment:7 by SF/madshi, 17 years ago

My Simon1 doesn't show dialog text on screen. The dialogs
are audio only. The audio overlaps. Well, at least it proves
that the mixer is working well... :-)

comment:8 by eriktorbjorn, 17 years ago

Ah, now I understand what you mean. I've heard that
happening a few times, but never spontaneously. I.e. it's
always been when I've tried to do something to interrupt
something else.

I wonder how many different versions of Simon the Sorcerer
there are anyway. There seem to be two on the CD I bought,
and I have no idea what the difference between them is...

comment:9 by SF/madshi, 17 years ago

I have 2 Simon1 CDs with 3 different versions. But I think all 3
versions have the same overlap problem. Just try out the
barbarian save game, it's extreme there!

comment:10 by eriktorbjorn, 17 years ago

I see what you mean. I'll let you know if I figure anything
out, but don't count on anything soon. I'm still very new to
ScummVM, and the Simon interpreter probably isn't the
easiest place to start digging.

comment:11 by SF/madshi, 17 years ago

No problem at all. Simon1 is absolutely playable as it is. It's
just a minor bug. Thank you!

comment:12 by fingolfin, 17 years ago

Owner: fingolfin removed
Summary: SIMON: Dialogs overlap quite oftenSIMON: Voice dialogs overlap quite often

comment:13 by Kirben, 17 years ago

Does the voice overlaping problems still occur ? I think the
barbarian voice overlaps are fixed but not sure about the other
scene with four wizards.

comment:14 by SF/madshi, 17 years ago

I'm sorry, but the overlapping is still there for me with the
german version, also (and most noticably) with the barbarian.
And it does not overlap in the original simon exe. There are
several other situations where the dialogs overlap more or
less noticably. It seems to me, that the synchronization is
not really stable yet...

comment:15 by Kirben, 17 years ago

Unfortunately I can't reproduce this one either, I get no voice
overlaps at all in barbarian scene since problem of sound
effects cutting off speech was fixed.
The only time I get voice overlap in the fours wizards scene in
pub is when they are chatting as I attempt to talk to them.

I have noticed a few spots that cause a double voice (Looking
at books in Sordid's Tower) and when voice cuts off too early
(When talking to Soridd) but none with just voice overlapping.

comment:16 by SF/madshi, 17 years ago

The interesting thing is that both the dialog overlap and the
graphical glitch in the barbarian scene occur exactly at the
same time, namely when the barbarian begins to thank
Simon for helping him. Perhaps after all those 2 effects have
to do with each other? I don't know.

How about this: You're working on Simon2, perhaps some
fixes you will do there will secretly fix my Simon1 problems.
So if you ask me, you could close this bug report now as not
reproducable. I can some weeks/months later, when Simon2
is at 90-95%, check out those barbarian problems again. If
they still occur then, I can post a new bug report. What do
you think?

comment:17 by Kirben, 17 years ago

I will keep this bug report open for now, even though I can't re-
repduce it. It will be a long time before Simon 2 is close to
95% complete.
Could you check if problem has been resolved by changes in
the last few days ? as there have been several sound related
changes recently.

comment:18 by Kirben, 17 years ago

Component: Engine: AGOS
Game: Simon the Sorcerer 1

comment:19 by Kirben, 17 years ago

Component: Engine: AGOS
Game: Simon the Sorcerer 1

comment:20 by SF/madshi, 17 years ago

I'll check it again as soon as possible.

comment:21 by SF/madshi, 17 years ago

With the current daily win32 build it still overlaps for me.

comment:22 by SF/sir_kill_a_lot, 17 years ago

This bug also occurs with my german version of Simon the
Sorcerer (Talkie and Win) using the latest daily snapshot for
windows (ScummVM 0.3.1cvs Built on Feb 15 2003 10:27:54).

One example to reproduce: at the beginning of the game go
to the blacksmith und try "give door to blacksmith" and
Simon will say two sentences simultaniously.

comment:23 by Kirben, 16 years ago

Game: Simon the Sorcerer 1Simon the Sorcerer 2
Summary: SIMON: Voice dialogs overlap quite oftenSIMON1TALKIE: Voice dialogs overlap quite often

comment:24 by Kirben, 16 years ago

Most of these particular speech overlaps seems limited to
English/German versions of simon1talkie. The last examples
given on this bug report and on forums don't occur in
simon1win or in simon1talkie versions
(French/Hebrew/Italian/Spanish) with combined
speech/subtitles.
The only obvious different between these versions, is the
English/German versionns are missing the subtitles for these
lines, although I'm not sure why that would make a
difference....

comment:25 by Kirben, 16 years ago

All voice overlaps should now be fixed in ScummVM cvs, all
the cases reported on this bug report no longer occur. I was
finally able to reproduce that barbarian one too, never choose
that particular response before.
Please confirm all the voice overlaps are gone and if you
notice any other spots, please list the exact responses used.

comment:26 by SF/madshi, 16 years ago

It seems to be fixed now!

And - the barbarian overdraw graphical glitches I reported
(don't know whether you remember) seem to be gone at the
same time!

Well done! :-)

comment:27 by Kirben, 16 years ago

Status: newclosed

comment:28 by Kirben, 16 years ago

Owner: set to Kirben
Resolution: fixed

comment:29 by fingolfin, 14 years ago

Component: Engine: AGOSEngine: AGI
Game: Simon the Sorcerer 2Space Quest 2

comment:30 by Kirben, 13 years ago

Component: Engine: AGIEngine: AGOS
Game: Space Quest 2Simon the Sorcerer 1
Note: See TracTickets for help on using tickets.