Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#3403 closed defect

DOTT: Chron-o-john "rotor" missing (script bug)

Reported by: SF/coeins Owned by:
Priority: low Component: Engine: SCUMM
Keywords: original Cc:
Game: Day of the Tentacle

Description

The animation of the Chron-o-john "rotor" and the "glowing" of the toilet are missing in some situations.
Tested with DOTT Floppy/German and ScummVM/Win32 0.10.0 as well as 0.11 daily snapshot (9/13/07).

I've attached a series of screenshots to illustrate the problem. It should be reproducible with the following steps:

(1) Use Savegame with Chron-O-John already connected to power source. (The rotor on top should be moving)
(2) Put an object into the Chron-O-John. The toilet starts to glow, the rotor disappeares completely.
(3) Switch to another person and back. The rotor is moving again, but now the glowing of the toilet is missing.
(4) Take the object out of the Chron-O-John. The rotor disappeares again.
(Works with Hoagie and Laverne)

I don't think this is a serious problem, but i guess it shouldn't behave like this...

Ticket imported from: #1794309. Ticket imported from: bugs/3403.

Attachments (2)

dott.jpg (82.0 KB ) - added by SF/coeins 12 years ago.
Screenshot-sequence
tentacle-de.s10 (28.4 KB ) - added by SF/coeins 12 years ago.
Savegame

Download all attachments as: .zip

Change History (12)

by SF/coeins, 12 years ago

Attachment: dott.jpg added

Screenshot-sequence

by SF/coeins, 12 years ago

Attachment: tentacle-de.s10 added

Savegame

comment:1 by SF/coeins, 12 years ago

File Added: tentacle-de.s10

comment:2 by fingolfin, 12 years ago

Summary: DOTT Chron-o-john "rotor" missingDOTT: Chron-o-john "rotor" missing

comment:3 by fingolfin, 12 years ago

Hmm, are you sure that this is not how the "original" engine behaved, too? I am pretty sure I saw this being reported before and it turned out that this is just how the game behaves there. It might seem incorrect, but it's how they coded it.

So, somebody should test it with the original engine.

comment:4 by SF/coeins, 12 years ago

Finally I found the time to play the original engine. You're right, it's indeed original behaviour. I should've checked that before... shame on me.

comment:5 by fingolfin, 12 years ago

OK, so we can either close this as won't fix, or add it to the list of "bugs in the original game which we can try to find a workaround for"... Seems DOTT and Sam have quite some of those, BTW ;-).

comment:6 by fingolfin, 12 years ago

Priority: normallow

comment:7 by sev-, 12 years ago

Summary: DOTT: Chron-o-john "rotor" missingDOTT: Chron-o-john "rotor" missing (script bug)

comment:8 by fingolfin, 12 years ago

Keywords: original added

comment:9 by sev-, 11 years ago

This bugreport has been moved to Wiki to relevant Engine/TODO page. When the bug will be resolved, an appropriate message will be posted here and the bugreport link removed from Wiki

comment:10 by sev-, 11 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.