Opened 17 years ago

Closed 16 years ago

Last modified 12 years ago

#333 closed defect (fixed)

SIMON1DOS: Brief freeze when talking to demons

Reported by: (none) Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: script Cc:
Game: Simon the Sorcerer 1

Description

[using latest cvs build (win32) with simon1dos english
version]

the game freezes when you're talking to the demons at 2
points.
1. right after starting the conversation if you say
"Well, you look like demons! Ha Ha.. Ha?" one of the
demons starts to talk and the game freezes when he says
"fluttered"
2. if you take the first dialogue option instead at the
beginning of the conversation the first bug won't
occur. after talking a bit one of the demons will ask
for smokes though and regardless of what you say the
game will freeze.

savegame is attached

Ticket imported from: #578336. Ticket imported from: bugs/333.

Attachments (1)

SAVE.001 (2.8 KB) - added by (none) 17 years ago.
Simon1 Savegame right before bug

Download all attachments as: .zip

Change History (26)

Changed 17 years ago by (none)

Attachment: SAVE.001 added

Simon1 Savegame right before bug

comment:1 Changed 17 years ago by fingolfin

Summary: Simon1dos: freeze when talking to demonsSIMON: Freeze when talking to demons

comment:2 Changed 17 years ago by fingolfin

Priority: normalhigh

comment:3 Changed 17 years ago by (none)

Logged In: NO

Same problem with Linux version.

comment:4 Changed 17 years ago by SF/madshi

I had an endless loop when talking to the barbian with the
fragment in the foot. At one situation the barbarien talky was
through, but the mouth keeped moving forever. After
restarting the game I was not able to reproduce the effect,
though.

Is your freeze the same thing? Mouth still moving, but the
rest is frozen? Or is everything frozen?

comment:5 Changed 17 years ago by (none)

Logged In: NO

actually it's the exact opposite .. the mouth stops moving,
but the candles in the background for example keep on moving

comment:6 Changed 17 years ago by (none)

Logged In: NO

I am having the exact same problem and have no idea how to
fix it!! If you figure it out, let me know

comment:7 Changed 17 years ago by (none)

Logged In: NO

Does anyone know how to fix this problem?? I don't think
there is a way to advance any further in the game without
finishing talking to the demons, which doesn't help if it
crashes every time.

Thanks

comment:8 Changed 17 years ago by wjp

This looks like a race. When adding output statements to
o_wait_for_vga and the function that clears the
_wait_for_vga flag:

waiting for VGA 200
VGA 202 done
VGA 200 done
waiting for VGA 200 done
waiting for VGA 202

It _is_ possible to get past it, since every once in a while
these vga's will finish in the proper order.

comment:9 Changed 17 years ago by SF/ender

This was fixed by a recent patch, I believe? Is this closable yet?

comment:10 Changed 17 years ago by (none)

Logged In: NO

nope, still hangs with the latest cvs build

comment:11 Changed 17 years ago by Kirben

Priority: highblocker

comment:12 Changed 17 years ago by Kirben

This problem occurs every time in simon1dos target but I was
unable to reproduce problem in simon1talkie and simon1win
targets when starting a new game.

comment:13 Changed 17 years ago by Kirben

Component: Engine: AGOS
Game: Simon the Sorcerer 1

comment:14 Changed 17 years ago by Kirben

Component: Engine: AGOS
Game: Simon the Sorcerer 1

comment:15 Changed 17 years ago by Kirben

A work around has been added to scummvm cvs, the game
still freezes briefly but than continues.

comment:16 Changed 17 years ago by Kirben

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:17 Changed 16 years ago by Kirben

Leaving open since it is still an issue, although only causes
brief freeze now.

comment:18 Changed 16 years ago by Kirben

Keywords: script added
Owner: Kirben deleted
Priority: blockernormal
Status: closednew
Summary: SIMON: Freeze when talking to demonsSIMON: Brief freeze when talking to demons

comment:19 Changed 16 years ago by Kirben

There is also a brief freeze when the Swampling leaves his
house in simon1dos, just as Simon is about to talk.

comment:20 Changed 16 years ago by Kirben

Summary: SIMON: Brief freeze when talking to demonsSIMON1DOS: Brief freeze when talking to demons

comment:21 Changed 16 years ago by SF/andrej4000

The freese is beacuse the interpreter waits for an animation
to end, while it ended before.
Would it be a way to implement additional checks for
animations?

The problems is with wait_for_vga. If a workaround will be
implemented, then it would be neccessary to implement a
dynamic table, which contains boolean var wether the
animation runs or not.
In that case the wait_for_vga would check in the beginning if
it really has to wait or not.

comment:22 Changed 16 years ago by Kirben

Owner: set to Kirben

comment:23 Changed 16 years ago by Kirben

Status: newclosed

comment:24 Changed 14 years ago by fingolfin

Component: Engine: AGOSEngine: AGI
Game: Simon the Sorcerer 1Space Quest 1

comment:25 Changed 12 years ago by Kirben

Component: Engine: AGIEngine: AGOS
Game: Space Quest 1Simon the Sorcerer 1
Note: See TracTickets for help on using tickets.