Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#3298 closed defect (fixed)

SYMBIAN UIQ3: All AGOS hang on startup

Reported by: SF/noelemahc Owned by: anotherguest
Priority: blocker Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

Using the latest stable 0.10.0 release of the Symbian UIQ3 version of ScummVM on a SonyEricsson W950i.

Tested with Simon the Sorcerer 1 floppy and CD versions, as well as floppy versions of Waxworks, Elvira 1 and Elvira 2; US releases all.

The problem is the same - upon launching any of the games from the menu, the screen goes black (which is normal behaviour), but it doesn't change out of it regardless of how long I wait (the longest managed so far was 10 minutes, though I'm willing to wait more). It apparently loads up the phone's memory or whatever as switching out to Task Manager and killing the process takes up quite a while too.
I know it to be normal as any SCUMM talkie games and Nippon Safes also spend a while with an empty black screen as they apparently parse/process/otherwise load the game resources, but they DO come out of it in less than a minute of waiting.

I assume this might've been expected with the newly-added HorrorSoft titles, but the fact that it also affects Simon is what made me worry.

Ticket imported from: #1749702. Ticket imported from: bugs/3298.

Change History (11)

comment:1 Changed 12 years ago by fingolfin

Owner: set to anotherguest
Summary: Symbian UIQ3 - All AGOS hang on startupSYMBIAN UIQ3: All AGOS hang on startup

comment:2 Changed 12 years ago by SF/noelemahc

Aw, fiddlesticks. After I've reinstalled ScummVM to see if I accidentally got the wrong version up and running (I haven't), Elvira did load after several minutes' worth of waiting. Even runs smooth-ish. So I guess this should be relegated from "Help, these games don't work at all" to "Ouch, these games take a <...> while to load!". I will get back to you when (if) it turns out that Simon Talkie was also affected.

comment:3 Changed 11 years ago by sev-

What is the status of this item?

comment:4 Changed 11 years ago by SF/noelemahc

As of the latest released unstable build posted by port maintainer AnotherGuest (dated 24th November), the load times have increased by about 50%, but the Elvira games still behave well after the preliminary 5 to 7 minutes of loading (presumably) have passed. Both Simon games are still ridiculously sluggish when they do finally load. That is to say, the digital sound works perfectly in talkie versions, BUT the animations and MIDI music perform at about 70% of normal speed. Not lethal, but most certainly unpleasant.

comment:5 Changed 11 years ago by anotherguest

Will have to investigate the original of the totally sluggish performance/file accesses (probably)

comment:6 Changed 11 years ago by sev-

Priority: normalblocker

comment:7 Changed 11 years ago by sev-

Raising priority. This is a release-critical bug.

comment:8 Changed 11 years ago by anotherguest

Now added a caching mechanism on file reads, just barely tested, so need to get the votes in if this is fixed and its working 100%. Reading one byte at a time was and is not really effciant on Symbian OS.

Strange bug.. tested with SIMON2.. and talkie version of Simon2 starts in five seconds with old version. So there are some other issues with SIMON1 or some kind of compression etc.

comment:9 Changed 11 years ago by sev-

What is the status of this item?

comment:10 Changed 11 years ago by anotherguest

Status: newclosed

comment:11 Changed 11 years ago by sev-

Resolution: fixed
Note: See TracTickets for help on using tickets.