Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#3299 closed defect (worksforme)

SYMBIAN UIQ3: FotAQ does not start

Reported by: SF/noelemahc Owned by: anotherguest
Priority: normal Component: Engine: Queen
Keywords: Cc:
Game: Flight of the Amazon Queen

Description

Using the latest stable 0.10.0 release of the Symbian UIQ3 version of
ScummVM on a SonyEricsson W950i.

Tested with the freeware one-file talkie version found on the ScummVM site.

The problem is the same as in my other, AGOS-based, report - upon launching the game from the menu,
the screen goes black (which is normal behaviour), but it doesn't change
out of it regardless of how long I wait (the longest managed so far was 10
minutes, though I'm willing to wait more). It apparently loads up the
phone's memory or whatever as switching out to Task Manager and killing the
process takes up quite a while too.
I know it to be normal as any SCUMM talkie games and Nippon Safes also
spend a while with an empty black screen as they apparently
parse/process/otherwise load the game resources, but they DO come out of it
in less than a minute of waiting.

Since this game has been supported for a while, I really want to know if it's a bug or a technical limitation imposed by the game's one-file state and the original version should be used instead. It should be noted that SCUMM talkie games work near-flawlessly and therefore it may not be a technical limitation after all.

Ticket imported from: #1749704. Ticket imported from: bugs/3299.

Change History (7)

comment:1 Changed 12 years ago by fingolfin

Owner: set to anotherguest
Summary: Symbian UIQ3 - FotAQ does not startSYMBIAN UIQ3: FotAQ does not start

comment:2 Changed 12 years ago by SF/noelemahc

Okay, slight correction - this only occurs with the MP3-compressed version. The uncompressed version takes about three to four minutes to load up (180 megs of indirectly-interpreted code really might do so, I'd think), but then works smooth as butter. Apparently, I'm prone to panic attacks and posess a ridiculously short attention span.

comment:3 Changed 12 years ago by anotherguest

This is due to that the MP3 support for FOTAQ is not working properly for the Symbian port. OGG and uncompressed version work well.

comment:4 Changed 12 years ago by anotherguest

This is due to that the MP3 support for FOTAQ is not working properly for the Symbian port. OGG and uncompressed version work well.

comment:5 Changed 11 years ago by sev-

What is the status of this item?

comment:6 Changed 11 years ago by anotherguest

Tested with 0.11.0 release version.
FOTAQ Mp3 version (FULL) available from ScummVM download page.
Loading takes VERY long time!
Game starts without any problems (I think this was fixed when increasing the stacksize for the mp3/common threads)

comment:7 Changed 11 years ago by anotherguest

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.