Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2892 closed defect (fixed)

HE: When 3x graphics are choosen, F5 crashes game

Reported by: SF/daniel9 Owned by: sev-
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Freddi Fish 2

Description

I ran into a strange bug. Never noticed it until I got a new monitor and selected 3x graphics, instead of 2x. When I run one of the Humongous games, pressing F5 crashes the game, showing the following message in the console:

ScummVM 0.10.0svn (Nov 4 2006 16:19:09) Console is ready Debugger started, type 'exit' to return to game Type 'help' to see a little list of commands and variables. ERROR: Widget <scummsaveload_list> has x + w > 640 (734)

typing 'exit' will quit the game. This exact error occures both in windowed and fullscreen mode. The game plays normaly, only loading or saving is impossible.

After switching back to 2x graphics the problem disappears.

Tested this also with release version 0.9.1, but that one has no problem at all!

Problem can also be seen in the following other Humongous titels: freddi3 both english and dutch freddi4 both english and dutch freddi5 both english and dutch pajama pajama2 pajama3 putttime dog and probably many more.

I tried to run ScummVM with debug level 10, that gives quite a lot of text, but it does not mention this error at all. Strange....

System: Mac G4, OS X 10.4.8, scummVM 0.10.0svn november 4th 2006.

Ticket imported from: #1590596. Ticket imported from: bugs/2892.

Change History (9)

comment:1 by fingolfin, 14 years ago

Owner: set to sev-
Summary: HE: MACOSX: When 3x graphics are choosen, F5 crashes gameHE: When 3x graphics are choosen, F5 crashes game

comment:2 by fingolfin, 14 years ago

I strongly doubt that this is Mac OS X specific. Sounds more like a bug in the save/load dialog code or so

comment:3 by eriktorbjorn, 14 years ago

I wasn't able to reproduce it on my Linux box. The error message is probably this one, from newgui.cpp:

if (_x + _w > g_system->getOverlayWidth()) error("Widget <%s> has x + w > %d (%d)", _name.c_str(), g_system->getOverlayWidth(), _x + _w);

But why on earth would getOverlayWidth() return 640 for a 3x scaler...?

comment:4 by (none), 14 years ago

ScummVM 0.10.0svn (Nov 4 2006 12:17:58) Features compiled in: Vorbis FLAC MP3 zLib MPEG2

Confirmed for the AmigaOS4 build Widget <scummsaveload_list> has x + w > 640 (734)!

gcc version 4.0.2 (AmigaOS build 20051012)

comment:5 by sev-, 14 years ago

I can't reproduce it here. How do you select 3x mode? on the fly?

comment:6 by SF/daniel9, 14 years ago

In the main menu, I select 'Options' and at the graphics tab, I choose graphics mode 3x, render mode <default> and no full screen but with Aspect ratio correction. If I try to start one of the games right after that, the problem occures, or if I restart ScummVM after that, and start one of the games, it also crashes.

The main reason I wanted the 3x graphics, was to have longer lines in the menu.

The humongous games all run in 640x480, so applying 3x graphics will result in 1920x1440. My monitor can only display 1280x1024 max, so maybe this is part of the problem.

Oh no! I just tried everything from last weekend again, but now everything seems to work correctly.

I feel very silly. I have really tried all the above games, and the problem came back every time I had changed the setting to 3x. I was also very surprised to find that version 0.9.1 did not exhibit this problem. Nothing changed on my machine the last few days, I am talking about the exact same copy of the SVN build, and the game files haven't changed either.

As I am unable to recreate this problem, maybe vampir_raziel can tell you more.

comment:7 by (none), 14 years ago

>As I am unable to recreate this problem, maybe >vampir_raziel can tell you more.

At your service :-)

Bug is still here for me

3x changed in options menu, quit ScummVM (i for one can't do that resolution change on-the-fly, at least not for the menu unless i quit and restart, game itself has the new resolution then - hey would make a great feature request :-)) and restart.

Started Pajama Sam 1, crashes as soon as you press F5 Widget <scummsaveload_list> has x + w > 640 (734)!

tested with a new build from today: ScummVM 0.10.0svn (Nov 7 2006 15:24:03) Features compiled in: Vorbis FLAC MP3 zLib MPEG2

I'm on a 1900x1200 resoltion here, no other log output, also no -d3 output which would be useable.

If any more information is needed, i'll gladly try to gather it

comment:8 by sev-, 14 years ago

Fixed in SVN. Thanks for reporting.

comment:9 by sev-, 14 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.