Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2891 closed defect (wontfix)

SIMON1TALKIE: Unknown MD5

Reported by: SF/themadventurer Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: detection Cc:
Game: Simon the Sorcerer 1

Description

ScummVM version: ScummVM 0.9.1 (Nov 2 2006 05:52:59) Features compiled in: Vorbis FLAC MP3 zLib MPEG2

Language: spanish+italian+hebrew+french (multilanguage edition) Bug details: MD5s of your game version are unknown. Please, report following data to ScummVM team along with your game name and version: icon.dat: 22107c24dfb31b66ac503c28a6e20b19 icon.dat.: 22107c24dfb31b66ac503c28a6e20b19

Version: Simon the Sorcerer 1 DOS Talkie Platform: DragonFly BSD 1.6.1 GCC: gcc version 3.4.5 20050809 (prerelease) [DragonFly] (propolice, visibility)

Other details: - ScummVM build from pkgsrc ( http://pkgsrc.se/games/ scummvm ) - I've seen this MD5 on other messages, not sure why appears using ScummVM 0.9.1

Ticket imported from: #1590579. Ticket imported from: bugs/2891.

Change History (15)

comment:1 by SF/themadventurer, 14 years ago

Forgot to say... I don't understand why the same file appears repeated with a . more on the name, some bug on my build? icon.dat exists but not icon.dat.

Here is a ls -R: # ls -R disk.id effects.voc esp-hlp.wri hebrew/ install.dat italian/ itxt.heb itxt.spa mt_fm.ibk
simon.voc xmscheck.exe drivers.red esp-hlp.doc french/ icon.dat install.exe itxt.fre itxt.ita itxt.txt setd.snd spanish/

./french: gamepc runvga.exe setup.exe simon.gme stripped.txt tbllist

./hebrew: gamepc runvga.exe setup.exe simon.gme stripped.txt tbllist

./italian: gamepc runvga.exe setup.exe simon.gme stripped.txt tbllist

./spanish: gamepc runvga.exe setup.exe simon.gme stripped.txt tbllist

comment:2 by SF/themadventurer, 14 years ago

Forgot to say... I don't understand why the same file appears repeated with a . more on the name, some bug on my build? icon.dat exists but not icon.dat.

Here is a ls -R: # ls -R disk.id effects.voc esp-hlp.wri hebrew/ install.dat italian/ itxt.heb itxt.spa mt_fm.ibk
simon.voc xmscheck.exe drivers.red esp-hlp.doc french/ icon.dat install.exe itxt.fre itxt.ita itxt.txt setd.snd spanish/

./french: gamepc runvga.exe setup.exe simon.gme stripped.txt tbllist

./hebrew: gamepc runvga.exe setup.exe simon.gme stripped.txt tbllist

./italian: gamepc runvga.exe setup.exe simon.gme stripped.txt tbllist

./spanish: gamepc runvga.exe setup.exe simon.gme stripped.txt tbllist

comment:3 by Kirben, 14 years ago

Owner: set to Kirben

comment:4 by Kirben, 14 years ago

It isn't possible to play this version of Simon the Sorcerer 1 directly from the CD under ScummVM anymore.

If you want to leave the majority of data files on the CD: Copy the icon.dat to the hard disk. Add the game by manually editing ScummVM config file. Set game path to location of 'icon.dat' Set the extra path to language directory for game (ie french)

Otherwise just copy the complete data files for each language to the hard disk.

The filenames have an extra '.' at the end, when using Simon the Sorcerer 1/2 CDs under certain operating system (ie unix). That is why ScummVM checks for both 'filename' and 'filename.'.

comment:5 by SF/themadventurer, 14 years ago

Owner: Kirben removed

comment:6 by SF/themadventurer, 14 years ago

Forgot to say... I don't understand why the same file appears repeated with a . more on the name, some bug on my build? icon.dat exists but not icon.dat.

Here is a ls -R: # ls -R disk.id effects.voc esp-hlp.wri hebrew/ install.dat italian/ itxt.heb itxt.spa mt_fm.ibk
simon.voc xmscheck.exe drivers.red esp-hlp.doc french/ icon.dat install.exe itxt.fre itxt.ita itxt.txt setd.snd spanish/

./french: gamepc runvga.exe setup.exe simon.gme stripped.txt tbllist

./hebrew: gamepc runvga.exe setup.exe simon.gme stripped.txt tbllist

./italian: gamepc runvga.exe setup.exe simon.gme stripped.txt tbllist

./spanish: gamepc runvga.exe setup.exe simon.gme stripped.txt tbllist

comment:7 by SF/themadventurer, 14 years ago

Sorry for the repeated post, I updated wrongly and then the message was posted again. Please clean this if necessary.

I forgot to say that I copied the files to the hard disk drive and the problem is exactly the same.

I edited manually and put this on scummvmrc:

[simon1] gfx_mode=advmame3x description=Simon the Sorcerer 1 Talkie (French) music_volume=192 speech_volume=192 path=/var/teemp/simon1/ aspect_ratio=true extrapath=/var/teemp/simon1/french/ music_driver=auto subtitles=true platform=pc gameid=simon1 language=fr fullscreen=true sfx_volume=192 talkspeed=60 speech_mute=false

The error message:

Looking for simon1 Trying to start game 'Simon the Sorcerer 1' MD5s of your game version are unknown. Please, report following data to ScummVM team along with your game name and version: icon.dat: 22107c24dfb31b66ac503c28a6e20b19 icon.dat.: 22107c24dfb31b66ac503c28a6e20b19 WARNING: SimonEngine: Unable to locate game data at path '/var/teemp/simon1/'! WARNING: Failed to instantiate engine for target simon1!

comment:8 by fingolfin, 14 years ago

Owner: set to Kirben

comment:9 by Kirben, 14 years ago

I was mistaken in earlier message, using the extra path won't work in this situation.

You will need to copy the required data files for each language version, to a separate directory. ie For French verison, copy icon.dat, simon.voc and the contents of french directory to a single directory.

Check http://scummvm.sourceforge.net/documentation.php?view=datafiles for details on the exact data files required.

You can still use the extra path, to share the single speech file between all four language versions though.

comment:10 by Kirben, 14 years ago

Resolution: wontfix
Status: newclosed

comment:11 by SF/themadventurer, 14 years ago

Now when it tries to run the game (even the screen it's in black), scummvm crashes giving me the following message:

Looking for simon1 Trying to start game 'Simon the Sorcerer 1' [1] 441 segmentation fault (core dumped) scummvm

But only when using AdvMame3x/HQ3x/3x, with other scalers the game runs correctly. My screen resolution is 1280x1024.

A weird thing is that I didn't needed to copy the files in older ScummVM versions, why now it's needed? Why not autodetect the directories instead using this tricky method? It can be more user-friendly :)

Thanks a lot for the reply ;)

comment:12 by SF/themadventurer, 14 years ago

Please, anyone can reply this? It seems there are some weird bug with the filter, now sure if related to my platform (DragonFly BSD 1.6.1). I may test a SVN build here if needed.

About needing to copying files... Why not autodetecting this version instead moving files? Does it's difficult for the ScummVM game detector?

comment:13 by SF/themadventurer, 14 years ago

This tracker item is pending response by the submitter; we cannot continue processing it before that happens. As a consequence, its status has been set to "Pending". It will automatically revert to "Open" once a new comment is made to this item. If no response is made within 14 days, it will automatically be closed.

Thank you.

comment:14 by SF/themadventurer, 14 years ago

now=not.

Sorry for my bad english and the browser problem repeating the same message several times.

comment:15 by Kirben, 14 years ago

Component: Engine: AGIEngine: AGOS
Game: Space Quest 2Simon the Sorcerer 1
Note: See TracTickets for help on using tickets.