Opened 18 years ago

Closed 17 years ago

#262 closed defect (fixed)

MI1: German sz ligature

Reported by: SF/inguin Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

In the german version of Monkey Island 1, the german
sz ligature (Character 0xdf in iso-8859-1) isn't
displayed in the verbs+dialogs box, instead there is
an empty space about four letters wide. And since the
letter is quite common, the lower part of the screen
is constantly messed up.
Also, during the introduction text of the first
intermission (when leaving Scumm Bar for the first
time) the lower half of the sz letter is missing.

Ticket imported from: #556444. Ticket imported from: bugs/262.

Change History (8)

comment:1 by SF/inguin, 18 years ago

The problem seems to be more critical than I thought it
would be: By now I found three situations in the game
that make ScummVM segfault, always with a "WARNING: New
name of object too long" message:
Twice during the idol stealing sequences in Elaine's
house (it doesn't crash if I skip these scenes) and
then on Monkey Island, after blasting the dam and
getting the rope from Herman's friend (no way to
prevent it from segfaulting there).

comment:2 by fingolfin, 17 years ago

I can reproduce this with my german copy of MI1. You
can see it on the close verb: "Schlieen" is drawn as
"Schliee". Also, while the SZ is cut half in the big letter
text in the first cutscene (the one after leaving Scumm
bar), it appear correctly in conversation texts.

I'll try later to play thru to the crashes, maybe I can a) fix
them and b) find out this way what exactly is going
wrong.

comment:3 by SF/inguin, 17 years ago

Whatever you changed: In the latest CVS the "New name of
object too long" crash is gone. There are still quite a lot flaws
(especially in the Monkey Island [TM] catacombs), but at least
I was finally able to complete the game.

comment:4 by fingolfin, 17 years ago

Yeah I made a fix for the MI1 crasher. Please file bug
reports for any flaws you encounter (unless there is already
a bug report for it of course :-)

The SZ is still incorrect, but I don't know yet why... it
*should* be in the font set obviously. Also I really have no
clue why in the font used for the cutscenese the SZ is cut
off in the middle. Hrmpf.

comment:5 by fingolfin, 17 years ago

Scumm Encoding for SZ () is 0xE1.

In the first cutscene, the SZ in the word "Fluss" is cut
off. It's size is 11x14 according to printChar.

OTOH, the SZ in the word "Schliesse" (which is not drawn at
all has a size of 0x0 (explaining why it is not drawn). Of
course that's strange. Will investigate further.

comment:6 by SF/inguin, 17 years ago

The VGA disk version of MI1 is still listed among the "please
don't file bug reports" games (I didn't realize that before I
opened this bug). Am I supposed to do so anyway?

comment:7 by fingolfin, 17 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:8 by fingolfin, 17 years ago

Fixed in CVS.

Yes reporting bugs for the M1VGA is OK since it is
completeable now. Just make sure to test with latest CVS as
there have been various bug fixes for MonkeyVGA in the last
couple of days.

Note: See TracTickets for help on using tickets.