Opened 17 years ago

Closed 17 years ago

Last modified 10 years ago

#261 closed defect (fixed)

SAM: Highway Surfing Crashes On Exit

Reported by: (none) Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

ScummVM 0.2.0 Release
Built on May 15 2002 01:04:49
Linux-SDL

Sam 'n' Max Hit The Road, US Talkie CD

Losing the Highway Surfing minigame causes a sudden
rush of noise, followed by a crash with error

WARNING: SoundMixer::insert out of mixer slots!
Error: SoundMixer::channel_deleted chan not found!

Issue was not present in 5-13-02 build.

Ticket imported from: #556227. Ticket imported from: bugs/261.

Change History (10)

comment:1 by fingolfin, 17 years ago

Summary: Highway Surfing Crashes On Exit (S'n'M)SAM: Highway Surfing Crashes On Exit

comment:2 by fingolfin, 17 years ago

Does this still happen with a current build of ScummVM?

comment:3 by fingolfin, 17 years ago

Damn it is not easy to *loose* that game. I try to hit the
signs, but since they are drawn somewhat incorrectly, that's
extremly, and more often than not I accidentally score
points :-)

comment:4 by SF/linnard, 17 years ago

Cannot test--I no longer run Linux.

I could try it in the Windows version, but I'm pretty sure the
results wouldn't be considered very helpful.

comment:5 by fingolfin, 17 years ago

It doesn't seem to crash anymore, but rather gets stuck
and repeatedly prints:

WARNING: SoundMixer::out of mixer slots!

comment:6 by eriktorbjorn, 17 years ago

Does this still happen with the latest CVS? I wasn't able to
reproduce it when I tried it some days ago.

comment:7 by fingolfin, 17 years ago

It seems to be a bit better but still freezes over here.

comment:8 by fingolfin, 17 years ago

Works fine for me in latest CVS

comment:9 by fingolfin, 17 years ago

Resolution: fixed
Status: newclosed

comment:10 by Kirben, 10 years ago

Owner: set to fingolfin
Note: See TracTickets for help on using tickets.