Opened 14 years ago

Closed 13 years ago

#2518 closed defect (worksforme)

COMI: Guybrush walking backwards (Amiga)

Reported by: (none) Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

ScummVM 0.9.0svn (Mar 3 2006 07:21:57)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

Guybrush walks backwards!
Can easily be checked (at least here). In the very
first room (Wally and cannon) "defeat" Wally and stand
infront of the restraint rope. Now point towards the
cannon opening and let Guybrush walk.

Here he will walk the whole way to the end of the
cannon AND the part beside the door backwars until he
turns around and faces the opening.

Also some small parts on the first island he will#
walk backwards. (if it helps, i remember reading
about a similar, yet fixed bug, in ITE!)

AmigaOS4 build

Ticket imported from: #1442282. Ticket imported from: bugs/2518.

Attachments (1)

comi.s01 (72.4 KB ) - added by fingolfin 14 years ago.
Savegame sent to me via email by the bug submitter

Download all attachments as: .zip

Change History (12)

comment:1 by fingolfin, 14 years ago

First off: ITE is a completly different engine, and has nothing at all in common
with SCUMM. hence any issues seen there are completely unrelated.

As to this issue: I can't reproduce this at all on my Mac OS X system with latest
CVS. Please provide more specific instructions: Where precisely are you
standing? Ideally, provide a savegame in which one can trigger the issue with a
single click on the cannon opening.

comment:2 by fingolfin, 14 years ago

Owner: set to fingolfin
Status: newpending

comment:3 by (none), 14 years ago

Sorry, i just wanted to give a hint.

More Info:
Let Guybrush face the "Ring" where the Cannon restraint rope
is hooked on. He will stand and slightly face the opening.
Now just click around Guybrush's face (a red error pointing
out of the opening should appear) and let him walk.

For me he walks the entire path BEFORE the cannon and the door
backwards and will turn around at the cannon ball pile to
face the opening and start walking in the right direction
towards the opening.

I'll send a savegame to your sourceforge address, i hope you
don't mind, but it's too big for SF to be attached.

Thank you

comment:4 by (none), 14 years ago

Status: pendingnew

by fingolfin, 14 years ago

Attachment: comi.s01 added

Savegame sent to me via email by the bug submitter

comment:5 by fingolfin, 14 years ago

Thanks for the savegame. However, I still can't reproduce
the issue. Just to make sure i am doing the "right" thing: I
load your savegame using latest CVS. Then I click on the
window (to make it precise, I click on the part where one
can see the outside night sky / sea). Note that the mouse
cursor at that time is a red arrow pointing to the left.
Guybrush then walks correctly to the window.

In your email you mentioned endianess. Note that I am using
Mac OS X on PowerPC, so that can be ruled out. It's in fact
pretty unlikely that any endian bugs remain :-).

Is this the Amiga binary from our website?

comment:6 by (none), 14 years ago

>Thanks for the savegame. However, I still can't reproduce
>the issue.
Oi, that will be a tough one then :-(

>I load your savegame using latest CVS. Then I click on
>the window (to make it precise, I click on the part where
>one can see the outside night sky / sea). Note that the
>mouse cursor at that time is a red arrow pointing to the
>left.
You are doing it exactly as i do

>MacOS X
This is big endian, then?

>Is this the Amiga binary from our website?
Nope, freshly build from svn sources today
0.8.2 from the website does it too

comment:7 by fingolfin, 14 years ago

Yes, PowerPC is big endian. So it sounds more and more like
a either a big endian issue, or a problem with your data
files. Maybe you know other AmigaOS users whom you could try
to reproduce this?

I'll try to contact the AmigaOS packager about this.

comment:8 by (none), 14 years ago

I have a PPC and big endian on Amiga, too.

I'll try to contact others and ask to try it.

comment:9 by SF/capehill, 14 years ago

(I'm the current maintainer of AmigaOS 4 port)

I was able to reproduce this with the 0.8.2 build. It
doesn't seem to matter if Wally is "defeated" or shooting
out from the window.

I just walk to the constraint rope and after that, a click
to almost anywhere else (grate, keyhole, cannon balls,
window) makes Guybrush walk backwards.

It's hard to believe that this is an Amiga-only bug but it's
always natural to suspect an optimizer bug when everything
else fails ;) I try to build ScummVM SVN with GCC 4.0.2 when
I get my SDK sorted out, instead of GCC 3.4.2...

comment:10 by fingolfin, 14 years ago

Well I am pretty much convinced that this is a port specific
bug. After all, this is a pretty obvious bug, and COMI has
been under testing for years now -- it's very unlikely that
such a fat bug right at the start would have gone unnoticed
all the time. Plus I can't reproduce it neither under OS X,
nor under Windows, while two AmigaOS users can reproduce
it... pretty strong hints, that :-).

comment:11 by fingolfin, 13 years ago

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.