Opened 17 years ago

Closed 17 years ago

Last modified 16 years ago

#239 closed defect (fixed)

plank by the Scumm Bar kitchen

Reported by: SF/logicdeluxe Owned by: SF/ender
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

Built on May 9 2002 10:56:58 win
Monkey1 multilingual CD
If you go to the plank Guybrush starts kicking the
plank in an endless loop instead of only once per mouse
click. This bug is introduced recently.

Ticket imported from: #554122. Ticket imported from: bugs/239.

Change History (6)

comment:1 by fingolfin, 17 years ago

I can reproduce this with the MI1 version for MacOS,
too.

comment:2 by SF/mnepomuk, 17 years ago

...MI1 VGA Floppy too.

comment:3 by SF/ender, 17 years ago

Owner: set to SF/ender
Resolution: fixed
Status: newclosed

comment:4 by SF/ender, 17 years ago

Fixed, I think.

comment:5 by fingolfin, 16 years ago

What happens here: a script checks the distance of guybrush to a
specific object. If that distance is less than 3, the plank is
"activated". So after you stepped on the plank, in regular Monkey
EGA (non-demo), we get this (I added some printf's):

(294,131); (298, 134) -> (297,133); dist (3, 2)
Get dist 1 - 902: 3

The first two coordinate pairs are the coords of actor 1 and obj
902 (printed from getObjActToObjActDist). The third are the
coordinates of object 902 after adjustXYToBeInBox() has been
applied. Finally the resulting x/y distance are shown (the
maximum of which is the final distance)

For PASS now, we get:
(294,131); (296, 133) -> (296,133); dist (2, 2)
Get dist 1 - 307: 2

Since this distance is less than 3, the plank will be triggered again
and again and again. Note that Guybrush's pos is identical to that
in the regular MonkeyEGA, however the position of the target
object differs.

Also note that obj 307 is used instead of obj 902, but that is
irrelevant (room & costume ids also differ, but that is no surprise,
given that PASS combines three game demos into one data set).

comment:6 by fingolfin, 16 years ago

Aargh - of course my last comment was not meant for this (long
closed) bug report. Ignore it.

Note: See TracTickets for help on using tickets.