Opened 17 years ago

Closed 17 years ago

Last modified 12 months ago

#238 closed defect (invalid)

Soundsystem stops under Windows XP

Reported by: SF/th3d4rk Owned by: SF/ender
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

When i try to play a game with -enull on windows cause
i want to hear MP3 music and i start scummvm the
sounde mute. i had to press pause/play to continue
playing mp3 and if i change to the scummvm-task it's
mute again. dunno know if it's only happen with
mediplayer cause dont using other player

WinXP
Soundblaster Live! (current XP driver)

the unbelievable is that it happen with any -e option

Ticket imported from: #554117. Ticket imported from: bugs/238.

Change History (3)

comment:1 by SF/ender, 17 years ago

This is caused by the initilisation of SDL_AUDIO, which
happens regardless of the music engine (audio is still
enabled for sound effects).

There is not plan to alter this at the moment, although I
will see if I can ask SDL to init music as wavonly or in
DirectSound corperative mode.

Closing as it's not a real bug. It will either work if I
find a way to get SDL to do so, or it won't if I cant or
don't have time ;)

comment:2 by SF/ender, 17 years ago

Owner: set to SF/ender
Resolution: invalid
Status: newclosed

comment:3 by digitall, 12 months ago

Component: --Unset--Port: Win32
Note: See TracTickets for help on using tickets.