Opened 17 years ago

Closed 17 years ago

Last modified 8 months ago

#240 closed defect (fixed)

Mouse cursor craphics are cut off

Reported by: SF/logicdeluxe Owned by: fingolfin
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

Built on May 9 2002 10:56:58 win
While moving the mouse the mouse cursor graphics is cut
off. This happens to all kind of cursors and in all
graphics modes. The cursor appears fine as long as the
mouse isn't moved. This is introduced recently.

Ticket imported from: #554123. Ticket imported from: bugs/240.

Change History (7)

comment:1 Changed 17 years ago by fingolfin

Owner: set to fingolfin

comment:2 Changed 17 years ago by fingolfin

What graphics backend do you use (SDL, X11, Amiga,
etc..).

If it is the SDL backend, I applied some fixes to that very
recently, maybe they either cause or fix what your
problem :-)

Can you please describe what *exactly* you do to see
them cut off - which game, are you moving the mouse
in special way, etc. - i can't see the problem over here
right now, maybe I am looking in the wrong place!

comment:3 Changed 17 years ago by SF/logicdeluxe

I noticed this in Windows SDL.
To reproduce this, just move the mouse. The cut off part is
always on the sprite's edge the mouse is currently moving
to. I have taken a screenshot with it. For example it
appears like in the screenshot (cut off from the bottom and
from the right edge) if you move the mouse toward the lower
right. This happens to all games.
http://www.gratissaugen.de/files/mouse.JPG

It stil happens with Built on May 10 2002 00:14:06

comment:4 Changed 17 years ago by fingolfin

Yes I see what you mean - it only happens if I move the
mouse, and due to the pulsing, it's immediatly "fixed"
again, that's why I didn't notice it at first.

comment:5 Changed 17 years ago by fingolfin

And in addition, I usually use one of the "advanced"
scalers, much harder to spot in there; using the plain
2x scaler the problem pretty obvious. Anyway, fixed now
(I hope - otherwise, feel free to reopen this bug).

comment:6 Changed 17 years ago by fingolfin

Resolution: fixed
Status: newclosed

comment:7 Changed 8 months ago by digitall

Component: --Unset--Port: Win32
Note: See TracTickets for help on using tickets.