Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#2255 closed defect (fixed)

ZAK256: Italian Translation doesn't start

Reported by: SF/licantrop0 Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

Recently, an active group of Italian translators, has translated the FmTowns version of Zak McKraken. Here is the patch: <http://www.oraparloio.org/ust/index.php? ind=downloads&op=entry_view&iden=4> (click on "Scarica File")

The problem is that with ScummVM 0.7.1 stable, the game start without problems, except this message:

Looking for zakTowns Trying to start game 'Zak McKracken and the Alien Mindbenders (FM-TOWNS)' Unknown MD5 (d7681f89ea70da03ad3717d34e24271f)! Please report the details (language, platform, etc.) of this game to the ScummVM team WARNING: o5_resourceRoutines 36 not yet handled (script 34)!

If I try to load the same game with ScummVM 0.8.0 (last CVS Build), here is the critical error that I display:

Looking for zakTowns Trying to start game 'Obsolete Target' WARNING: Target upgraded from zakTowns to zak! Unknown MD5 (d7681f89ea70da03ad3717d34e24271f)! Please report the details (language, platform, etc.) of this game to the ScummVM team Unknown magic id (0xFE08) - this version is unsupported!

and ScummVM closes itself.

then, if I try to load again with the Stable version 0.7.1, here is a new error:

Looking for zak Trying to start game 'Zak McKracken and the Alien Mindbenders' Unknown MD5 (d7681f89ea70da03ad3717d34e24271f)! Please report the details (langu age, platform, etc.) of this game to the ScummVM team (0:0:0x0): Unknown magic id (0xFE08) - this version is unsupported!

and ScummVM closes itself.

Note that now the Game ID is "zak" and not zakTowns! That is the big problem!

Thank you very much for your work, i love ScummVM and you guys are fantastic.

Ticket imported from: #1326581. Ticket imported from: bugs/2255.

Change History (19)

comment:1 by SF/licantrop0, 15 years ago

Summary: Italian Translation of Zak FmTowns do not startItalian Translation of Zak FmTowns doesn't start

comment:2 by SF/licantrop0, 15 years ago

Summary: Italian Translation of Zak FmTowns doesn't startZakTowns: Italian Translation doesn't start

comment:3 by fingolfin, 15 years ago

Generally, custom localizations aren't officially supported by us.

However, there is a workaround: you can specify a custom target_md5 manually in the config file. Just add target_md5=2d4536a56e01da4b02eb021e7770afa2 to the config entry for your italian zak, and it should work again. Does it?

comment:4 by fingolfin, 15 years ago

Owner: set to fingolfin
Resolution: invalid
Status: newpending
Summary: ZakTowns: Italian Translation doesn't startZAK256: Italian Translation doesn't start

comment:5 by SF/licantrop0, 15 years ago

Status: pendingnew

comment:6 by SF/licantrop0, 15 years ago

With your workaround works fine with 0.8.0 CVS (yea!), but not with 0.7.1, givin' same error :(

However, thanks for the advice! :)

This Italian translation is maded very well, either more than original one. Please, try to support it!

Regards, Licantrop0

comment:7 by sev-, 15 years ago

0.7.1 isn't supported anymore. We're gearing to new release. See http://www.scummvm.org So hopefully in less than 2 week you will have it in stable release.

comment:8 by sev-, 15 years ago

Status: newclosed

comment:9 by fingolfin, 15 years ago

I have to kindly disagree: Of course we do support 0.7.1, we'd be a strange project if we didn't support our own latest stable release anymore :-). However in case of bugs we usually do refer to the latest (potentially unstable) CVS builds.

In this particular case, the config file "format" has changed in the latest versions; hence after you used the CVS version, the config file was upgraded, this is why 0.7.1 doesn't work for you anymore.

As for the italian translation: well it may be good, I don't doubt that, but we do not usually support anything but official game titles; fan translation aren't something we actively support. However, we do not intend to actively block them, either, which is why we added the target_md5.

Still, I think we could be a little bit more "friendly" towards such fan mods of the FM-TOWNS games, by adding a couple checks (like, "IF game == zak AND platform == fmtowns AND md5 unknown THEN assume it is ZakTowns and setup everything accordingly". What do you think, Eugene?

comment:10 by sev-, 15 years ago

Owner: changed from fingolfin to sev-
Resolution: invalid
Status: closednew

comment:11 by sev-, 15 years ago

Yes, we could do that, it's a matter of adding yet another table ooh. Which would be the list now? All FM-TOWNS titles? And is that pre- or post- release feature?

Saying 'do not support' I mean that we aren't going to fix any bug there, but anyway :).

comment:12 by fingolfin, 15 years ago

This is a feature for the next major release, I'd say. And it's not only needed for FM-TOWNS, it's needed for *all* games...

In most cases, the target name plus (optionally) the platform & language are fully sufficient for us to run. In those cases where it isn't, we can still do what we do now (i.e. abort, though maybe with a nice alert telling the reasons).

I.e. if target = comi -> no need to know the MD5, platform, lang if target = zak -> need to know platform & lang; we can already distinguish V1/V2 If target = monkey -> we need to distinguish EGA, VGA, CD. The CD version is V5, the others are V4, so we can distinguish them. Oh an dhte SEGA/FM-TOWNS versions are unique, too, of course. Not sure if we can automatically distinguish EGA/VGA, but that might be possible, too.

This is maybe not a matter of just adding a simple table, but it's the price you have to pay for unifying the target names. See Engine_SCUMM_detectGames for some starting points on how to distinguish SCUMM games w/o MD5.

comment:13 by fingolfin, 15 years ago

Oh and of course <http://wiki.scummvm.org/index.php/Auto_detection>.

comment:14 by sev-, 14 years ago

Owner: changed from sev- to fingolfin

comment:15 by sev-, 14 years ago

Fingolfin, I guess you'll handle it with your brnad new detection helper code?

comment:16 by fingolfin, 14 years ago

OK, this should work much better now, at least in theory. In particular, zak for FM-TOWNS can easily be distinguished from the 'regular' zak.

Licantrop0, I would very much appreciate if you could do some testing for me: Could you (at least temporarily) remove any target_md5 config entries / files from your system and then try to (a) detect your italian Zak FM-TOWNS, and (b) try to run it ?

comment:17 by SF/licantrop0, 14 years ago

With 0.8.2 stable, do not works (detecting and running) With 0.9.0 26 Apr, it worsk perfectly without md5!!! :D

now I have problems with Original Loom CD Italian Version... maybe I have to open a new bug...

comment:18 by fingolfin, 14 years ago

Great

comment:19 by fingolfin, 14 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.