Opened 15 years ago

Closed 15 years ago

Last modified 17 months ago

#2084 closed defect (fixed)

Compile error with gcc4.0

Reported by: SF/mnbv Owned by: eriktorbjorn
Priority: normal Component: Port: Linux
Keywords: Cc:
Game:

Description

ScummVM version : CVS (2005-07-06)

g++ -Wp,-MMD,"scumm/.deps/actor.d",-MQ,"scumm/actor.o",-MP -Wall -g -ansi -W -Wno-unused-parameter -O -Wuninitialized -Wno-long-long -Wno-multichar -Wno-unknown-pragmas -pedantic -Wpointer-arith -Wcast-qual -Wconversion -Wshadow -Wimplicit -Wundef -Wnon-virtual-dtor -Wno-reorder -Wwrite-strings -fcheck-new -DHAVE_CONFIG_H -DUNIX -DDISABLE_KYRA -I. -I. -I/usr/include/SDL -D_REENTRANT -Itest/cxxtest -c scumm/actor.cpp -o scumm/actor.o ./scumm/intern.h:795: error: ISO C++ forbids declaration of 'ResExtractor' with no type ./scumm/intern.h:795: error: expected ';' before '*' token ./scumm/intern.h:1116: error: ISO C++ forbids declaration of 'LogicHE' with no type ./scumm/intern.h:1116: error: expected ';' before '*' token make[2]: *** [scumm/actor.o] Error 1 make[2]: Leaving directory `/home/grahame/scummvm'

Linux Debian amd64 Unstable with gcc 4.0.1

Ticket imported from: #1233194. Ticket imported from: bugs/2084.

Change History (6)

comment:1 by sev-, 15 years ago

Even GCC team says that 4.0 is too raw for wide use. They suggest to wait at least 4.01 for any ranges of production. 4.0 was released just because "deadline overdued" not because it was really ready. So fixing bugs after compiler declared buggy.... Fingolfin?

comment:2 by fingolfin, 15 years ago

Owner: set to fingolfin
Resolution: wontfix
Status: newclosed

comment:3 by fingolfin, 15 years ago

Note in particular that this report was made for "gcc 4.0.1" - which is not a released version of GCC, to my knowledge...

I can't reproduce the issue with GCC 4.0.0.

comment:4 by eriktorbjorn, 15 years ago

After a brief discussion with Fingolfin, I've applied a patch that made it compile on my "unstable" Debian box. Hopefully that means this bug is fixed now.

comment:5 by eriktorbjorn, 15 years ago

Owner: changed from fingolfin to eriktorbjorn
Resolution: wontfixfixed

comment:6 by digitall, 17 months ago

Component: Port: Linux
Note: See TracTickets for help on using tickets.