Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#2085 closed defect (fixed)

FOTAQ: Crash when loading

Reported by: SF/dark2025 Owned by: cyxx
Priority: normal Component: Engine: Queen
Keywords: Cc:
Game: Flight of the Amazon Queen

Description

ScummVM v0.7.1 Default Settings The game is the freeware CD version from the site. I am using Windows XP Professional with SP2

The game crashes with "Assertion failed: pbf->data != 0, file queen/bankman.cpp, line 125" every time a saved game is loaded if the saved game happens to be saved before the very last action to be performed in the game.

Ticket imported from: #1233495. Ticket imported from: bugs/2085.

Attachments (2)

queen.s00 (12.0 KB ) - added by SF/dark2025 15 years ago.
Very end of FOTAQ
queen_debug.log (86.1 KB ) - added by SF/dark2025 15 years ago.
Debug Log

Download all attachments as: .zip

Change History (9)

by SF/dark2025, 15 years ago

Attachment: queen.s00 added

Very end of FOTAQ

comment:1 by sev-, 15 years ago

Summary: Crashes when loadingFOTAQ: Crash when loading

comment:2 by sev-, 15 years ago

May you try this with daily CVS build? 0.7.1 is pretty old now and many bugs were fixed.

comment:3 by fingolfin, 15 years ago

Owner: set to cyxx

comment:4 by cyxx, 15 years ago

I am unable to reproduce the crash with both CVS and 0.7.1 versions. I did various checks but right now I have no idea what could lead to this situation...

Can you (dark2025) run scummvm in debug mode until it crashes and attach the log to this report ? You can do this by executing the following command : scummvm -d9 -x0 queen > queen_debug.log

comment:5 by SF/dark2025, 15 years ago

It's interesting, using your debugging suggestion, I discovered that if I load the game in the command prompt (ie. "scummvm -x0 queen") the game will load properly, however, if I just type "scummvm queen" and using the journal item to load the game ScummVM will crash. I have attached a log of this crash.

by SF/dark2025, 15 years ago

Attachment: queen_debug.log added

Debug Log

comment:6 by cyxx, 15 years ago

Indeed, there was a problem if you use the journal in this room (not if you press F1, which is what I did first). This should be fixed in CVS now.

comment:7 by cyxx, 15 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.