Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2002 closed defect (invalid)

BS1 Segmentation Fault affter Opening Cutscene

Reported by: SF/spookybarn Owned by: eriktorbjorn
Priority: normal Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

I am attempting to run Broken Sword 1 from a directory.
I have copied all the files from the CD as instructed
by your documentation, including the music and speech
files, and the video pack from your website. The
opening cutscene plays correctly, and then the program
immediately exits. The error message displayed is:

Fatal signal: Segmentation Fault (SDL Parachute Deployed)

# ScummVM version (scummvm -v)
ScummVM 0.8.0CVS (Apr 22 2005 11:48:21)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2
(I have also tried the 0.7.1)

# Bug details, including instructions on reproducing
See Above

# Language of game (English, German, ...)
English

# Version of game (Talkie, Floppy, ...)
UK Sold-Out 2CD version

# Platform and Compiler (Win32, Linux, ...)
Windows XP Pro

# Attach a save game if possible
Unable to reach actual gameplay and save.

# If this bug only occured recently, please note the
last version without the bug, and the first version
including the bug. That way we can fix it quicker by
looking at the changes made.
Only got the game today.

Ticket imported from: #1187805. Ticket imported from: bugs/2002.

Change History (5)

comment:1 by SF/spookybarn, 14 years ago

Summary: Segmentation Fault affter Opening CutsceneBS1 Segmentation Fault affter Opening Cutscene

comment:2 by eriktorbjorn, 14 years ago

I've never heard any any problem like that, and I have the
Sold-Out version, too.

I believe the files BS1 needs this early in the game are
compacts.clu, general.clu, paris1.clu, scripts.clu and
swordres.rif

Paris1.clu is likely to be the game data that is specific to
one section of the Paris area. The others are probably used
throughout the game. The BS1 engine tests for the presence
of each of these files, apparently, but perhaps one of them
were corrupted or truncated when copying them from the CD.
Could you try re-copying them?

(I don't know why this would happen, but you'd be surprised
how many bug reports we get that turn out to be corrupted
data files.)

comment:3 by SF/spookybarn, 14 years ago

I recopied the data files, and the problem seems to be
resolved. Thanks, I should have tried that. I apologize
submitting a report for something so silly.

comment:4 by SF/spookybarn, 14 years ago

Status: newclosed

comment:5 by eriktorbjorn, 14 years ago

Owner: set to eriktorbjorn
Resolution: invalid
Note: See TracTickets for help on using tickets.