Opened 15 years ago

Closed 15 years ago

#2003 closed defect

BS2: blank screen after talk with shaman.

Reported by: SF/megath Owned by:
Priority: normal Component: Engine: Sword2
Keywords: Cc:
Game: Broken Sword 2

Description

after tezcatlipoca story from shaman, voice continues,
but scummvm
shows only black screen and ambient sounds.

Ticket imported from: #1188529. Ticket imported from: bugs/2003.

Attachments (1)

sword2.003 (682 bytes ) - added by SF/megath 15 years ago.
save game

Download all attachments as: .zip

Change History (12)

comment:1 by fingolfin, 15 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 by fingolfin, 15 years ago

Component: Engine: Sword2
Game: Broken Sword 2
Status: newpending
Summary: bs2: blank screen after talk with shaman.BS2: blank screen after talk with shaman.

by SF/megath, 15 years ago

Attachment: sword2.003 added

save game

comment:3 by SF/megath, 15 years ago

Status: pendingnew

comment:4 by SF/megath, 15 years ago

additional info :
scummvm from cvs.
choose 'talk to shaman' after loading attached savegame.
full english version of BS2, with mpeg cutscenes.
linux-2.6.8, gcc-3.3.5

comment:5 by eriktorbjorn, 15 years ago

That savegame doesn't work for me, so I guess my version of
BS2 is different from yours. (Mine is the Sold-Out version.)

When I try it with one of my old savegames, the screen
remains black for about 10 seconds, until the "lead-out"
sound has finished. Then the game continues. Your version
behaves differently?

comment:6 by SF/megath, 15 years ago

yes, after cutscene, game seems to continue, but nothing is
visible.
I guess I have original broken sword iso images. btw,
scummvm doesnt complain about anything in console. just
blank screen.

comment:7 by eriktorbjorn, 15 years ago

Does the same thing happen if you press ESC during the cutscene?

comment:8 by eriktorbjorn, 15 years ago

I've made a slight change so that it no longer waits for the
"lead-out" sound to finish when playing the "shaman"
cutscene, as it's obviously meant to blend in with the rest
of the game in a way that most other cutscenes don't.

But judging by your description that won't fix your problem,
since you said the image doesn't come back even after that
sound has finished.

comment:9 by eriktorbjorn, 15 years ago

There's been another bugfix to the MPEG player which should
keep it from hanging if the sound ends prematurely. It
shouldn't affect this bug since I don't believe you would
hear any background sound if this is where it got stuck.

Still, it would be good if you would test a more recent
snapshot. (I don't know how long it will take for the change
to make it into the public CVS archive.)

comment:10 by eriktorbjorn, 15 years ago

Status: newclosed

comment:11 by eriktorbjorn, 15 years ago

Still can't reproduce the bug. Still waiting to hear if the
recent changes made any difference. Marking as "pending".

Note: See TracTickets for help on using tickets.