Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1869 closed defect (worksforme)

FT (MAC): Crash when fighting Rottwheeler

Reported by: SF/thewyvern Owned by: fingolfin
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

Scumm Version: ScummVM 0.7.0 (Dec 23 2004 23:23:39)
Features compiled in Vorbis FLAC MP3 zLib MPEG2

Game: Full Throttle MAC (ftmac), CD Version extracted
to HD using HFVExplorer under WinXP (Service Pack 2).
It's the Original CD version I found in bundle with my
old Apple Performa.

Language: English

Bug: game crashes after a few seconds whe Ben starts
fighting the first Rottwheeler. You can reproduce the
bug following these steps:

1)Get FT Mac Original CD Version and mount it under
Windows with HFVExplorer (in order to find the data
file you must set on the option "Show Invisible File"
in HFVExplorer).
2)Find "Full Throttle Data" file and copy it to a
folder in your HD
3)Launch ScummVM, select the folder where you saved the
data file. ScummVM recognizes the game correctly.
4)Launch the game and load the attached Save Game File
5)Take the moto and fight the Rottwheeler...

After the game Crashes ScummVM reports a "Unknown MD5!"
error. Looks like ScummVM can't find an audio file.

Solution: skip the combat, but you lose a cutscene.

Ticket imported from: #1094674. Ticket imported from: bugs/1869.

Attachments (1)

ftMac.s01 (6.1 KB) - added by SF/thewyvern 14 years ago.
Save game before crash

Download all attachments as: .zip

Change History (33)

Changed 14 years ago by SF/thewyvern

Attachment: ftMac.s01 added

Save game before crash

comment:1 Changed 14 years ago by SF/thewyvern

Summary: Unknown MD5 Error palying Mac VersionUnknown MD5 Error playing Mac Version

comment:2 Changed 14 years ago by SF/thewyvern

Summary: Unknown MD5 Error playing Mac VersionFT: Unknown MD5 Error playing Mac Version

comment:3 Changed 14 years ago by fingolfin

Summary: FT: Unknown MD5 Error playing Mac VersionFT (MAC): Crash when fighting Rottwheeler

comment:4 Changed 14 years ago by fingolfin

There is no "MD5 error", only a "MD5 warning". Sounds more
as if there is a problem with the SMUSH movie playback;
maybe some of the code does not properly load the movie
data from the special mac data file. Hard to test w/o having
FT or Dig in the mac versions.

Is there no other output?

comment:5 Changed 14 years ago by SF/thewyvern

No, there's no other input. But the game crashes only when
Ben is hitted and the proper sound must be played. If I try
to avoid the Rottwheeler's punch for a few seconds, the game
doesn't close.
I'm available for testing if you want.

comment:6 Changed 14 years ago by SF/thewyvern

I extracted "Full Throttle Data" single file into its
components using Rescumm tool. After this operation, the
game runs without problems or crashes. So the problem is in
the native support for Mac Single Data Files, added to
ScummVM 0.7.0. The built-in functions you use can't
extract\find some audio files.

comment:7 Changed 14 years ago by fingolfin

Owner: set to fingolfin
Priority: normalhigh

comment:8 Changed 14 years ago by fingolfin

Heh, actually, I just found out I actually *do* have the mac
versions of FT and The Dig (my cousin gave them to me a
long time ago), I just had lost them in the bin. I really need
to catalog my collection, I have far too many CDs and
floppy stacks floating around everywhere. Five versions of
MI1 alone... :-)

This should make it considerably easier to find & fix the bug :-)

comment:9 Changed 14 years ago by fingolfin

I can't reproduce the problem. The only crash i encounter is
Ben's bike crashing after the fight, hard, but that's normal :-)

Anything special i should do in the fight to provoke the crash?

comment:10 Changed 14 years ago by SF/thewyvern

Nothing, just hit the Rottwheeler.
However remember that the problem shows only if you load the
game from the Single Mac Data File, not from the files
extracted with Rescumm.
As I told you, extracting the files actually solves the
problem (because Scumm doesn't read directly from the Single
Data File).

comment:11 Changed 14 years ago by fingolfin

Of course, we already know that the extracted versions
of the games work fine. So all my tests were done with
the single big mac data file. The english version, to be
precises. I couldn't reproduce the issue at all.

What is the MD5 of your "Full Throttle Data" file ?

comment:12 Changed 14 years ago by fingolfin

Resolution: worksforme

comment:13 Changed 14 years ago by SF/thewyvern

I don't know how to check MD5.
Can you explain me how?

comment:14 Changed 14 years ago by fingolfin

Google for "windows md5" and you'll find plenty tools which allow
you to compute the MD5 checksum of an arbitrary file.

comment:15 Changed 14 years ago by SF/thewyvern

Thanx.
My "Full Throttle Data" file MD5 is:
5BDE23F2B23BB7B27E523DF9DF2AFE40

comment:16 Changed 14 years ago by fingolfin

That matches my version of the game.

Hm. My best guess is that this is somehow a windows specific
bug. Maybe Windows has a problem with a program accessing
a single file through multiple file handles...

comment:17 Changed 14 years ago by SF/thewyvern

Is it possible to solve it?

comment:18 Changed 14 years ago by fingolfin

The issue is pretty hard to debug for me since I don't have a
Windows system to work with; and I am afraid most of my team
mates won't have the Mac version of The Dig / FT. But I'll ask
around, maybe somebody has it or has an idea.

comment:19 Changed 14 years ago by fingolfin

Could you please download the demo of either The Dig or FT
(or both), in the mac version, from our demos page?
<http://scummvm.sourceforge.net/demos.php>

Then, please tell me whether you can reproduce the problem(s)
with the demo. In the meantime, we'll test on various systems
with the demos, too, to see if we can reproduce the problem
somewhere.

comment:20 Changed 14 years ago by SF/thewyvern

OK! But you'll have to wait for a few day, because at home I
connect with a 56k modem.... Next tuesday or friday I'll go
to my father's office, where he has T1 connection.

comment:21 Changed 14 years ago by fingolfin

Actually, cancel that: I just found out that the demo files we
link to are unpacked versions of the mac demos, so they
won't tell us anything.

Maybe we can upload the regular "packed" version somewhere,
until then, no need to waste your bandwidth :-)

comment:22 Changed 14 years ago by Kirben

The Macintosh version of The Dig demo has been updated,
the link on demos page is now the packed version.

comment:23 Changed 14 years ago by SF/thewyvern

I downloaded The Dig Mac Demo packed version.
There's only an "Unknown MD5!" warning when I start the
demo, but audio and voices work fine.

comment:24 Changed 14 years ago by SF/thewyvern

Any news?

comment:25 Changed 14 years ago by SF/thewyvern

Any news?

comment:26 Changed 14 years ago by SF/evilbachus

This bug affects the Mac version of ScummVM as well. Copied "Full
Throttle Data" into a folder on my hard drive, started it up in ScummVM
0.7.0, and it crashes the second the dialogue in the first Rottwheeler fight
ends.

Console says this while starting up:

Looking for ftMac
Trying to start game 'Full Throttle (Mac)'
Unknown MD5! Please report the details (language, platform, etc.) of this
game to the ScummVM team

Says this during the crash:

Fatal signal: Bus Error (SDL Parachute Deployed)
Mar 3 03:49:20 GeeFive crashdump: Started writing crash report to: /
Users/bachus/Library/Logs/CrashReporter/scummvm.crash.log
2005-03-03 03:49:20.060 scummvm[2509] *** _NSAutoreleaseNoPool():
Object 0x11b6ca0 of class NSCFArray autoreleased with no pool in place -
just leaking
2005-03-03 03:49:20.060 scummvm[2509] *** _NSAutoreleaseNoPool():
Object 0x1167e80 of class NSCFString autoreleased with no pool in place
- just leaking
2005-03-03 03:49:20.061 scummvm[2509] *** _NSAutoreleaseNoPool():
Object 0x112f5c0 of class NSCFNumber autoreleased with no pool in
place - just leaking
2005-03-03 03:49:20.061 scummvm[2509] *** _NSAutoreleaseNoPool():
Object 0x11c0200 of class NSCFDictionary autoreleased with no pool in
place - just leaking
2005-03-03 03:49:20.061 scummvm[2509] *** _NSAutoreleaseNoPool():
Object 0x11bfec0 of class NSCFNumber autoreleased with no pool in
place - just leaking
2005-03-03 03:49:20.061 scummvm[2509] *** _NSAutoreleaseNoPool():
Object 0x1141d60 of class NSCFDictionary autoreleased with no pool in
place - just leaking
2005-03-03 03:49:20.061 scummvm[2509] *** _NSAutoreleaseNoPool():
Object 0x11b5710 of class NSCFArray autoreleased with no pool in place -
just leaking
2005-03-03 03:49:20.061 scummvm[2509] *** _NSAutoreleaseNoPool():
Object 0x1141db0 of class NSCFArray autoreleased with no pool in place -
just leaking
2005-03-03 03:49:20.062 scummvm[2509] *** _NSAutoreleaseNoPool():
Object 0xa2dc937c of class NSCFString autoreleased with no pool in
place - just leaking
2005-03-03 03:49:20.063 scummvm[2509] *** _NSAutoreleaseNoPool():
Object 0x11b3640 of class NSCFArray autoreleased with no pool in place -
just leaking
2005-03-03 03:49:20.063 scummvm[2509] *** _NSAutoreleaseNoPool():
Object 0x11b30a0 of class NSCFArray autoreleased with no pool in place -
just leaking
2005-03-03 03:49:20.063 scummvm[2509] *** _NSAutoreleaseNoPool():
Object 0x1149cd0 of class SDL_QuartzWindow autoreleased with no pool
in place - just leaking
Mar 3 03:49:20 GeeFive crashdump: Finished writing crash report to: /
Users/bachus/Library/Logs/CrashReporter/scummvm.crash.log

Partial crash report:

Thread: 1

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000644

Thread 1 Crashed:
0 org.scummvm.scummvm 0x0030156c 0x1000 + 0x30056c
1 org.scummvm.scummvm 0x0009dca4 0x1000 + 0x9cca4
2 org.scummvm.scummvm 0x00079e64 0x1000 + 0x78e64
3 org.scummvm.scummvm 0x0007899c 0x1000 + 0x7799c
4 org.scummvm.scummvm 0x000a73fc 0x1000 + 0xa63fc
5 org.scummvm.scummvm 0x000a660c 0x1000 + 0xa560c
6 org.scummvm.scummvm 0x000ab938 0x1000 + 0xaa938
7 org.scummvm.scummvm 0x000a8cf4 0x1000 + 0xa7cf4
8 org.scummvm.scummvm 0x000a26c8 0x1000 + 0xa16c8
9 org.scummvm.scummvm 0x000a1e70 0x1000 + 0xa0e70
10 org.scummvm.scummvm 0x0009e980 0x1000 + 0x9d980
11 org.scummvm.scummvm 0x0009efac 0x1000 + 0x9dfac
12 org.scummvm.scummvm 0x0009c8b0 0x1000 + 0x9b8b0
13 org.scummvm.scummvm 0x001dd270 0x1000 + 0x1dc270
14 org.scummvm.scummvm 0x001dd158 0x1000 + 0x1dc158
15 org.scummvm.scummvm 0x001ee3f4 0x1000 + 0x1ed3f4
16 org.scummvm.scummvm 0x001e5ea4 0x1000 + 0x1e4ea4
17 org.scummvm.scummvm 0x001eeca4 0x1000 + 0x1edca4
18 org.scummvm.scummvm 0x001ef670 0x1000 + 0x1ee670
19 libSystem.B.dylib 0x900246e8 _pthread_body + 0x28

comment:27 Changed 14 years ago by SF/evilbachus

Doh, Ignore me. The newest CVS build apparently fixes this bug.

comment:28 Changed 14 years ago by SF/marecki

I've had the same problem (Full Throttle (Mac) in English, under Linux/
AMD64) with ScummVM 0.7.1; version ScummVM 0.8.0CVS (May 13
2005 23:19:10) is free of the crash, but the MD5 sum of the data file
(fe381e45117878b1e942cb876b050fd6) remains unknown.

comment:29 Changed 14 years ago by sev-

Figolfin, recently you fixed some bundle-related code in
sound code. Maybe this is already fixed?

comment:30 Changed 14 years ago by fingolfin

Possible, but since i never was able to reproduce the problem, I wouldn't
know. Depends on the bug submitter (or anybody else who used to be
able to reproduce the problem) to check this...

comment:31 Changed 14 years ago by sev-

Putting to Pending status due to lack of steps on how to
reproduce.

comment:32 Changed 14 years ago by sev-

Status: newclosed
Note: See TracTickets for help on using tickets.