Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#1870 closed defect (fixed)

DIG (MAC): No voices with mac version

Reported by: SF/thewyvern Owned by: fingolfin
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

Scumm Version: ScummVM 0.7.0 (Dec 23 2004 23:23:39)
Features compiled in Vorbis FLAC MP3 zLib MPEG2

Game: The Dig MAC (ftmac), CD Version extracted to HD
using HFVExplorer under WinXP (Service Pack 2). It's
the original CD I bought.

Language: English

Bug: ScummVM can't load speech file. The game plays
smoothly but you can't hear voices. While playing,
ScummVM reports a list of "Unknown MD5!" error, every
time a character speaks.

1)Get FT Mac Original CD Version and mount it under
Windows with HFVExplorer (in order to find the data
file you must set on the option "Show Invisible File"
in HFVExplorer).
2)Find "The Dig Data" file and copy it to a folder in
your HD
3)Launch ScummVM, select the folder where you saved the
data file. ScummVM recognizes the game correctly.
4)Launch the game and skip the first cutscene
5)While characters are talking do a CTRL-ALT-CANC and
look at the Command Prompt Window. You can see "Unknown
MD5!" errors occuring every time a character talks.

Ticket imported from: #1094680. Ticket imported from: bugs/1870.

Attachments (2)

Bug Picts.rar (154.6 KB ) - added by SF/thewyvern 15 years ago.
Picts about No voices bug 1
Bug Picts 2.rar (168.8 KB ) - added by SF/thewyvern 15 years ago.

Download all attachments as: .zip

Change History (28)

comment:1 by SF/thewyvern, 15 years ago

There's also another detail. The correct error report is:

WARNING: BundleMgr::openFile() Can't get open bundle file:
xxxxx!

where xxxx is digmusic.bun, or digvoice.bun! etc. etc.

comment:2 by fingolfin, 15 years ago

There is no "MD5 error", only a "MD5 warning". Sounds more
as if there is a problem with the SMUSH movie playback;
maybe some of the code does not properly load the movie
data from the special mac data file. Hard to test w/o having
FT or Dig in the mac versions.

It's very strange that it prints a MD5 message each time an
actor speak -- I am not aware of anything in our code that
could cause this, we only generate a MD5 warning
when the game is started, but not after that.

Is there any other ouput you get?

comment:3 by fingolfin, 15 years ago

Summary: DIG: Unknown MD5 Error playing Mac VersionDIG (MAC): No voices with mac version

comment:4 by SF/kaminari, 15 years ago

I have the French Mac version and I don't encounter this
problem. Only difference is that I don't directly use the data
file, I extracted it at the time of ScummVM 0.5.

comment:5 by SF/thewyvern, 15 years ago

There's no other output. I confirm that the warning is
printed every time a character talks. I think that's because
I didn't extract all files, but use the native support for
Mac games in ScummVM 0.7.0 feature. Maybe you extract the
necessary files at runtime?
I'm available for testing, if you want.

comment:6 by SF/thewyvern, 15 years ago

I extracted "The Dig Data" single file into its components
using Rescumm tool. After this operation, the game runs
without problems and I get all speech and voices. So the
problem is in the native support for Mac Single Data Files,
added to ScummVM 0.7.0. The built-in functions you use can't
extract\find audio and music files called "digmusic.bun" and
"digvoice.bun" (while Rescumm tool extract them correctly).

comment:7 by fingolfin, 15 years ago

Indeed, sounds like a problem with the code that allows
"native" access to those mac files. Sadly, I don't have mac
versions of FT / Dig (I think -- gotta dig again through my
LucasArts collection, but I am pretty sure I only have Sam&Max
and DOTT in the mac version). So testing is a bit hard.
Maybe you can try a test binary for me if I find a fix?

I'll look into this matter once I have some spare time.

comment:8 by fingolfin, 15 years ago

Owner: set to fingolfin

comment:9 by SF/thewyvern, 15 years ago

Of course.
Contact me when you are ready.

comment:10 by fingolfin, 15 years ago

Priority: normalhigh

comment:11 by fingolfin, 15 years ago

Can you tell me how that MD5 message you get looks *exactly* I.e. the
precise wording of the message...

comment:12 by fingolfin, 15 years ago

I can't reproduce the problem at all. All voices work fine.
And no "Unknown MD5!" except for one when I start the
game. Since our code only contains one spot where that
message is printed, namely at startup, I can't even start to imagine what
would cause your problem.

comment:13 by SF/thewyvern, 15 years ago

The problem shows only if you load the
game from the Single Mac Data File, not from the files
extracted with Rescumm.
As I told you, extracting the files actually solves the
problem (because Scumm doesn't read directly from the Single
Data File).
I continue to experience the problem loading from the Single
Data File.
Maybe I have got a different DIG version?
If so, why does it work when I extract iternal files with
Rescumm?

comment:14 by SF/thewyvern, 15 years ago

I attached a .rar file which contains some picts about my
original mac cd, the single data file, ScummVM loading and
warning occurring. You can notice how errors occur at
runtime in pict 4, 5 and 6.
Hope this can help.

by SF/thewyvern, 15 years ago

Attachment: Bug Picts.rar added

Picts about No voices bug 1

by SF/thewyvern, 15 years ago

Attachment: Bug Picts 2.rar added

comment:15 by SF/thewyvern, 15 years ago

I splitted the .rar into two archives to respect maximum
attachment dimension.

comment:16 by fingolfin, 15 years ago

Good idea, that with the screenshots -- it unclouded the mystery
a bit :-). Not the MD5 message is printed repeatedly -- rather,
the warning of the BundleMgr is printed repeatdly!
Major difference.... :-)

So it can't load digvoice.bun and digmusic.bun. That does work
fine for me (with the single file version of The Dig / Mac; no
rescumm was used).

What is the MD5 of your "The Dig Data" file?

comment:17 by SF/thewyvern, 15 years ago

I don't know how to check MD5.
Can you explain me how?

comment:18 by SF/thewyvern, 15 years ago

Thanx.
My "The Dig Data" file MD5 is:
50ADF71B1EE1DDC20929E41CCB771463.

comment:19 by fingolfin, 15 years ago

That matches my version of the game.

Hm. My best guess is that this is somehow a windows specific
bug. Maybe Windows has a problem with a program accessing
a single file through multiple file handles...

comment:20 by fingolfin, 15 years ago

I simply can't reproduce the issue described here, nor can anybody
else whom I asked to try and reproduce the issue.. Maybe it's
something silly and simple, like, the speech volume in your config
file is set to 0 ;-).

Hm, kaminari, you wrote that you have the french mac version, but
extracted. Could you try running ScummVM with your original, unextracted
copy? Does that work? On what OS/system are you running?

comment:21 by SF/kaminari, 15 years ago

Yup, I now confirm the problem...

Win2K SP4 and WinXP SP2
ScummVM 0.8.0 CVS (March 3 2005 11:03:08)
The Dig, French version for MacOS

I copied The Dig Data (630 MB) with TransMac and added the
game via the launcher.

By the way, I noticed that gameid=dig + platform=macintosh
only work when the resources are extracted (otherwise
ScummVM complains about missing dig.la0 etc). The correct
gameid for unextracted resources is DigMac, which is only
mentioned in the CLI with the -z argument (you might want to
update the Compatibility page with that info). Ok, the game
launches:

Trying to start game 'The Dig (Mac)'
Unknown MD5 (21a6592322f92550f144f68a8a4e685e)!

The intro movie nevertheless plays correctly with music and
speech. When the game starts with the crew hovering over
the Shuttle, there's no music nor speech anymore, only
sound effects. The following warning messages appear in the
shell:

WARNING: BundleMgr::openFile() Can't open bundle file:
digmusic.bun!
WARNING: BundleMgr::openFile() Can't open bundle file:
digvoice.bun!

The digvoice.bun warning is repeated every time a character
is talking. The unknown checksum message appears only
once when the game is launched.

For the record, gameid=DigMac also works (perfectly) with
the extracted resources, but the shell displays the following
warnings:

Trying to start game 'The Dig (Mac)'
WARNING: md5_file couldn't open 'The Dig Data'!
Unknown MD5 (c0682400140000000100000000000000)!

Hope that helps :-)

comment:22 by SF/marecki, 14 years ago

I've got the same problem here... The Dig (Mac) in English, Linux/
AMD64, ScummVM 0.7.1 and ScummVM 0.8.0CVS (May 13 2005 23:
19:10). The MD5 sum of the file (35a2d3040fa512f8232d9e443319d84d)
is unknown and neither the music nor the speech is played, with
warnings as already posted. Rescumming the data file causes the
problem to disappear.

comment:23 by fingolfin, 14 years ago

The MD5 should be recognized now. Also some other things
related to the built-in Mac support have been made, so if
you please could retest and tell me whether the problem
still occurs with a CVS build from today, that would be
great!

comment:24 by SF/kaminari, 14 years ago

I tested my unextracted French version with the latest Win32
CVS:

The Dig Data
+ gameid=dig
+ platform=macintosh

works a treat now :-)

Only thing is, the MD5 (21a6592322f92550f144f68a8a4e685e) is
still shown as unknown in the console window, but it doesn't
trigger any other error and doesn't seem to affect the game
either.

comment:25 by fingolfin, 14 years ago

Well, I was refering to marecki's MD5 only, Kaminari. I added yours (as
Dig/Mac/French) to our database now.

Thanks for re-testing.

comment:26 by fingolfin, 14 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.