Opened 15 years ago

Closed 15 years ago

#1768 closed defect (worksforme)

FOA: Game Crashes Upon Examining Lost Dialogue/Archae. Mag.

Reported by: SF/tbcarey Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

As of 09/15's daily snapshop [that is the earliest
snapshot I can isolate it to -- however it may have
been introduced in any snapshop post-09/03, the last
snapshop that worked for me], using the verb "Look At"
and selecting any item that would require a redrawing
of the screen, such as the Lost Dialogue Of Plato or
National Archaeology causes the game to crash with the
following message:

"Fatal signal: Segmentation Fault (SDL Parachute Deployed)"

Running the game with --debuglevel=9 shows the line
immediately above the preceding to be:

getResourceAddress(Costume,2) == 00E3F00C

I've attached a savegame so you can duplicate this
behavior. Simply load it and try looking at either the
book or the magazine.

Ticket imported from: #1030423. Ticket imported from: bugs/1768.

Attachments (1)

atlantis.s08 (16.3 KB ) - added by SF/tbcarey 15 years ago.

Download all attachments as: .zip

Change History (11)

by SF/tbcarey, 15 years ago

Attachment: atlantis.s08 added

comment:1 by SF/tbcarey, 15 years ago

Summary: Game Crashes Upon Looking At Lost Dialogue/Archaeology Mag.FOA: Game Crashes Upon Examining Lost Dialogue/Archae. Mag.

comment:2 by fingolfin, 15 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 by fingolfin, 15 years ago

Using my own savegame, i can't reproduce the problem. Can you
reproduce it when you start a new game?
I haven't tried your savegame yet, as you didn't specify for which
language it is etc.

comment:4 by SF/tbcarey, 15 years ago

Sorry for my negligance. I was in a hurry and forgot to
include those details. At any rate, here's the info that I
didn't already include (please see initial post for info on
isolating the builds the bug occurs in):

ScummVM Latest Win32 CVS Snapshot (09/18)
Fate Of Atlantis Talkie, English

As I said before I believe this bug was introduced sometime
after 09/13, because I had played the game without any
errors at that date up to the point of the savegame I've
included.

The crash can be reproduced by using any savegame or
starting a new game and looking at the magazine or Lost
Dialogue. I could include more savegames but I don't see the
point, as it will happen no matter what point in the game
I'm at.

comment:5 by fingolfin, 15 years ago

Owner: set to Kirben
Resolution: worksforme

comment:6 by fingolfin, 15 years ago

I can't reproduce the problem, though. Neither by starting a new game,
then looking at the journal, nor using various other savegames. Tried
both the talkie version, the mac version, and a german non-talkie.

Of course it might be a bug specific to the Win32 build (I am on Mac OS
X)... Kirben, can you reproduce this issue?

comment:7 by SF/kaminari, 15 years ago

Works fine here with the latest Win32 build (1558K exe file,
last update: September 18, 2004, 5:44 pm). Indy 4 US talkie.

comment:8 by fingolfin, 15 years ago

Thanks kaminari!

tbcarey, did you try recently (i.e. today) whether 0.6.1b really still works
fine for you? Maybe the data files got corrupted? You might want to tell
us the MD5 check sums of your ATLANTIS.000 and .001 files...

comment:9 by SF/tbcarey, 15 years ago

Status: newclosed

comment:10 by SF/tbcarey, 15 years ago

Okay, upon using the latest build [now], the Win32 CVS
Snapshot from 9/18 5:55pm [vs. the previous 9/18 5:50am]
the crash no longer occurs. The problem, therefore, has been
fixed by code introduced between 9/18 5:50am and 9/18
5:55pm. I don't know what has been fixed that has stopped
this from occuring, but I thought you might want to know
anyway in case it is accidentally reintroduced.

The bug was certainly caused by code rather than any sort of
corruption on my end, as it did not occur with 0.6.1b, with
the 09/13 snapshot, and now with the latest snapshot.

Anyway, glad it's fixed.

Note: See TracTickets for help on using tickets.