Opened 16 years ago

Closed 16 years ago

#1741 closed defect (fixed)

FOTAQ: DC: Can't Navigate Pointer in Journal Menu

Reported by: SF/metafox Owned by: cyxx
Priority: normal Component: Engine: Queen
Keywords: Cc:
Game: Flight of the Amazon Queen

Description

In the 24-08-2004 CVS build for Dreamcast, when viewing the journal in Flight of the Amazon Queen to load or save a game, the mouse pointer freezes.

You can navigate the menu by pressing the mouse button or the A key on the controller, then moving the cursor, then repeating. If you just try to move the cursor on it's own, it doesn't show it's position on the screen.

Ticket imported from: #1016446. Ticket imported from: bugs/1741.

Change History (11)

comment:1 by cyxx, 16 years ago

Owner: set to zeldin

comment:2 by cyxx, 16 years ago

I suspect the main loop in Journal not doing all what's needed for the Dreamcast port. As I am not familiar with this backend ; Marcus, can you look at journal.cpp lines 65-84 and see if you notice something wrong ?

comment:3 by cyxx, 16 years ago

Ok, I have an idea. I suppose that, contrary to the SDL backend, in order to the refresh the new pointer position on the screen, you have to call OSystem::updateScreen()...

I just added a call to it in Journal. Can someone test if the problem is still there ?

comment:4 by zeldin, 16 years ago

I haven't tested the new code, but I can confirm that you do need to call updateScreen() for the mouse pointer to be redrawn. poll_event() will just update the internal position variables.

comment:5 by cyxx, 16 years ago

So, is the problem still there ?

comment:6 by cyxx, 16 years ago

Owner: changed from zeldin to cyxx

comment:7 by fingolfin, 16 years ago

Status: newpending

comment:8 by fingolfin, 16 years ago

Mickey McMurray / metafox -- please respond!

comment:9 by SF/metafox, 16 years ago

Sorry for the late response time.

It works like a charm now.

comment:10 by SF/metafox, 16 years ago

Status: pendingnew

comment:11 by cyxx, 16 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.