Opened 15 years ago

Closed 15 years ago

#1740 closed defect (fixed)

COMI: There's only background behind dialogue lines

Reported by: SF/jellby Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

When there is a dialogue and you have several lines to choose from,
behind these lines only the background (no characters or objects) is
shown. This can be seen, for example, in the barber shop: talk to
Rottingham (or to Haggis when he's gone) and Guybrush disappears
behind the text (the background is "pasted" over him).

Tested with Spanish COMI directly from CD
Linux RedHat 7.3 (updated)
ScummVM 0.7.0CVS (Aug 20 2004 14:35:55)
Features compiled in: Vorbis MP3 ALSA zLib MPEG2

P.S. Sorry if this "bug" has been already submitted, I didn't find it.

Ticket imported from: #1015941. Ticket imported from: bugs/1740.

Change History (5)

comment:1 by eriktorbjorn, 15 years ago

It can also be seen in the very first room, while talking to
Wally.

It doesn't happen in 0.6.0, so it's a regression.

comment:2 by fingolfin, 15 years ago

Indeed. This is probably caused by Kirben's verb code changes; or
maybe by my charset rewrite.

Ah yeah, the times... I recall spending a lot lot of time getting this
part (verb background redraw) working properly... :-)

comment:3 by fingolfin, 15 years ago

Owner: set to Kirben

comment:4 by fingolfin, 15 years ago

Owner: changed from Kirben to fingolfin
Resolution: fixed
Status: newclosed

comment:5 by fingolfin, 15 years ago

Fixed in CVS.

Note: See TracTickets for help on using tickets.