Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1717 closed defect (fixed)

MI1VGA: Guybrush not scaled properly

Reported by: SF/kaminari Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

In some occasions, Guybrush's sprite is not resized properly when coming from or going to the background. Here is a savestate, but you don't need it, really. Just start a new game, go past the Scumm Bar and the archway, and you'll see what I mean.

Tested with latest CVS Win32 build (2004-08-12).

Ticket imported from: #1008466. Ticket imported from: bugs/1717.

Attachments (1)

monkey1_ami.zip (4.9 KB ) - added by SF/kaminari 16 years ago.
Savestate next to the archway

Download all attachments as: .zip

Change History (6)

by SF/kaminari, 16 years ago

Attachment: monkey1_ami.zip added

Savestate next to the archway

comment:1 by Kirben, 16 years ago

Owner: set to Kirben
Summary: MI1 Amiga: Guybrush not scaled properlyMI1VGA: Guybrush not scaled properly

comment:2 by Kirben, 16 years ago

This is caused by the patch added to fix bug #869003 and isn't specfic to Amiga version.

comment:3 by SF/madm00se, 16 years ago

The bug is that Actor.setScale only sets scalex and scaley. Making it set boxscale too fixes the issue. I verified that this doesn't regress the original bugfix.

comment:4 by Kirben, 16 years ago

Thanks, changed added to ScummVM cvs.

comment:5 by Kirben, 16 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.