Opened 16 years ago

Closed 16 years ago

#1718 closed defect (fixed)

DIG: Subtitle glitches and unstable (Regression)

Reported by: Kirben Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

Latest ScummVM cvs version. Compiled under mingw with GCC 3.4.0 and running under Windows XP. English version of The Dig (PC or Mac)

Subtitles in the Dig are sometimes cut off at left and right edges, so only see the center section of the subtitles. The game is very unstable now too, with all sort of odd crashes at random. Seems like memory corruption somewhere, would be worth having someone try under valgrind. I have attached screenshot of subtitle glitch and saved game in asteroid. Trying to release all the metal plates should be enough to trigger a crash with that saved game.

Ticket imported from: #1008621. Ticket imported from: bugs/1718.

Attachments (3)

dig.s14 (10.6 KB ) - added by Kirben 16 years ago.
At asteroid
glitch.png (38.6 KB ) - added by Kirben 16 years ago.
Glitch example
valgrind.txt (1.4 KB ) - added by Kirben 16 years ago.
Valgrind log

Download all attachments as: .zip

Change History (14)

by Kirben, 16 years ago

Attachment: dig.s14 added

At asteroid

by Kirben, 16 years ago

Attachment: glitch.png added

Glitch example

comment:1 by fingolfin, 16 years ago

Resolution: fixed
Status: newclosed

comment:2 by fingolfin, 16 years ago

Thanks, was a stupid coding mistake on my part: I forgot to adjust for the vertical scroll offset...

comment:3 by Kirben, 16 years ago

Resolution: fixed
Status: closednew

comment:4 by Kirben, 16 years ago

Unfortunately the Dig still seems unstable, try the Asteroid Lander game. It often crashes or subtitles for response after crash are missing/off screen.

comment:5 by fingolfin, 16 years ago

Owner: fingolfin removed

comment:6 by fingolfin, 16 years ago

Asteroid Lander always has been crashy like hell, no surprise considering it directly acceesse our video buffers.

No stack trace provided... right now I see no reason why this should be assigned to me, as it's not clear which of many many recent changes might be responsible for this (it's not even clear to me that it's a regression, the lander always crashed on me)

comment:7 by Kirben, 16 years ago

Owner: set to fingolfin

comment:8 by Kirben, 16 years ago

The Asteroid Lander game has been stable for a long time now (I often use it) and this is a recent regression. The corruption is causing ScummVM to trigger all sorts on odd asserts and errors in ScummVM under Windows. I was unable to get a useful backtrace when trying under gdb, so couldn't include one earlier. I tried running under valgrind under linux and managed to get a useful log, which shows an invalid write in charset renderer.

by Kirben, 16 years ago

Attachment: valgrind.txt added

Valgrind log

comment:9 by Kirben, 16 years ago

I forgot to mention about the subtitles been missing/off screen: When the new text rendering code was first added to ScummVM cvs, the subtitles of responses after a Lander crash always seem to be positioned correctly. A change since than seems to have caused the subtitles to go missing/off screen again.

comment:10 by Kirben, 16 years ago

Resolution: fixed
Status: newclosed

comment:11 by Kirben, 16 years ago

Asteroid Lander mini game works fine again now, along with position of subtitles responses after crash.

Note: See TracTickets for help on using tickets.