Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1716 closed defect (invalid)

SAM: End Credits Crash

Reported by: SF/guitarmaster Owned by: Kirben
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

ScummVM version: 0.6.1b
Language: English
Version: Floppy
Platform: Windows ME

During the end credits, if I move the mouse into the
lower half of the screen, the SCUMMVM debugger comes up
with an error.

Ticket imported from: #1008117. Ticket imported from: bugs/1716.

Attachments (2)

samnmax.s07 (5.1 KB) - added by SF/guitarmaster 15 years ago.
script-1.txt (6.1 KB) - added by Kirben 15 years ago.
Script 1 output

Download all attachments as: .zip

Change History (15)

Changed 15 years ago by SF/guitarmaster

Attachment: samnmax.s07 added

comment:1 Changed 15 years ago by SF/guitarmaster

Summary: End Credits CrashSAM: End Credits Crash

comment:2 Changed 15 years ago by Kirben

The issue is specific to disk version of Sam and Max and the
exact error is:
(90:62:0x35): readArray: invalid array 178 (0)

The issue occurs with latest ScummVM CVS too.

comment:3 Changed 15 years ago by fingolfin

Indeed, I can't reproduce the problem with my (CD) version... sadly I
don't have the floppy version, so i can't directly look into this.
Anyway, I just used bootparam 1430 to try the credits in the CD version.
Array 178 is used there, too, in the same spot. And that array *is*
getting inited in the boot script... Hm.

Does this crash also happen with the above bootparam, or only with the
savegame attached here?

comment:4 Changed 15 years ago by Kirben

Unfortunately there aren't any boot params in the disk version
of Sam & Max.

comment:5 Changed 15 years ago by Kirben

I can jump to room 90 (End credits room) though and the
issue doesn't occurs when I do that.

comment:6 Changed 15 years ago by fingolfin

OK, so I have to wonder if this isn't maybe a bug in the savegame...

Can one of you check whether array 178 is setup in script 1 for the
floppy version (like it is for the CD version) ?

Changed 15 years ago by Kirben

Attachment: script-1.txt added

Script 1 output

comment:7 Changed 15 years ago by Kirben

Yes, array 178 is setup in script 1 in the disk version too. I
have attached script 1 output.

comment:8 Changed 15 years ago by fingolfin

Well, all i can say then is: looks like this savegame is corrupt... how
"old" is it, i.e. do you still know with which version of ScummVM you
started playing it, guitarmaster?

We may have to close this unresolved if we can't find any way to
reproduce this w/ another save game or using boot params, I am afraid.

comment:9 Changed 15 years ago by fingolfin

Priority: normalhigh
Status: newpending

comment:10 Changed 15 years ago by SF/guitarmaster

I played it only about a week ago and I used the same
ScummVM version the whole time.

Maybe it's because I downloaded it from the internet and it
was a corrupt copy?

There were a bunch of other errors in the game too, but none
that made it crash.

comment:11 Changed 15 years ago by SF/guitarmaster

Status: pendingnew

comment:12 Changed 15 years ago by Kirben

Definately sounds like corrupt data files, so closing as invalid.
Try buying the game, we don't support warez!

comment:13 Changed 15 years ago by Kirben

Owner: set to Kirben
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.