Opened 15 years ago

Closed 15 years ago

#1618 closed defect (fixed)

COMI: Speech is stuttering

Reported by: SF/leerqbasic Owned by: aquadran
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

Using Scummvm 0.7.0CVS (May 5 2004 13:11:50) on
Windows XP.

I've had this problem for a long time, and I hoped it
was solved when I saw some sound fixes at the CVS
version, but alas; it appears that from the beginning
on, Guybrush and Wally produce stuttering voices
whenever they say something.

The same happens with the music in the loading screen,
but not always. Maybe a buffer underrun? My dvd player
certainly is fast enough, judging by the original game.
CPU usage during the flaw stays around 4-6%, not a
problem there.

Ticket imported from: #948485. Ticket imported from: bugs/1618.

Change History (7)

comment:1 Changed 15 years ago by fingolfin

Do you have any special audio related drivers installed? What kind of
audio system do you have anyway?

We have had similar reports in the past, but so far they always turned
out to be a problem with the sound config of the reporter...

comment:2 Changed 15 years ago by SF/leerqbasic

I have an integrated Intel AC'97 audio system with no
special drivers installed and full audio acceleration
enabled. As far as I know this problem does not occur with
any other ScummVM emulated game or SDL-powered application/game.

comment:3 Changed 15 years ago by SF/leerqbasic

I noticed that the stuttering only occurs during heavy
cd-rom activity. For example, the music in the title screen
("Act 1") stutters when the game is loading the scene
itself, or Guybrush stutters as the sound is buffered from
the cd. I'm going to try to copy the files to my harddisk,
although maybe the solution it's far from a *nice* solution ;-)

comment:4 Changed 15 years ago by SF/leerqbasic

Running the game from my harddisk solved the problem. Could
it be that the stuttering is caused by switching too much
between files on the cd-rom? (for example, buffering the
music while also trying to buffer the speech)

comment:5 Changed 15 years ago by aquadran

what is current status with latest cvs ?

comment:6 Changed 15 years ago by SF/leerqbasic

I tested the latest CVS version of ScummVM and happily
noticed the voices no longer stutter. Well, in fact they do,
but only while the cd is being read. As soon as the sounds
are loaded the voices play just fine. As for the music, it
stutters like hell when ScummVM is accessing the cd-rom.

comment:7 Changed 15 years ago by aquadran

Owner: set to aquadran
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.