Opened 15 years ago

Closed 15 years ago

#1619 closed defect (fixed)

DC/COMI: crash on startup movie

Reported by: (none) Owned by: zeldin
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

The game crashes on the startup movie on dreamcast
after 5 minutes.

thanks

Ticket imported from: #949355. Ticket imported from: bugs/1619.

Change History (15)

comment:1 Changed 15 years ago by (none)

this happens in the 0.6.0 stable version

comment:2 Changed 15 years ago by (none)

this happens in the 0.6.0 stable version

comment:3 Changed 15 years ago by fingolfin

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:4 Changed 15 years ago by fingolfin

Owner: set to zeldin
Summary: MI3: crash on startup movie (Monkey Island 3) - dreamcastCOMI: crash on startup movie (Monkey Island 3) - dreamcast

comment:5 Changed 15 years ago by (none)

I use "scummvm-0.6.0-dreamcast-plainfiles.tar.bz2" this mean
that I do not compile any version, because no
existing development environment.

Before the system crash LeChuck and Elaine are speaking to
each other.
Before this happen the Speech/sound is stuttering > picture
already there, sound after 2 seconds.
I think the system get muddled because of the long video at
the beginning.

Game: Monkey Island 3: The Curse of Monkey Island GERMAN PC
CDROM-Version.

There are no save games available because this is in the
beginning (and within 5 minutes)

comment:6 Changed 15 years ago by SF/tito13kfm

* ScummVM version: Stable Version 0.6.0 (Cannot test Daily
CVS builds because I cannot compile for Dreamcast)
* Language of game: English
* Version of game: Talkie
* Platform and Compiler: Dreamcast
* This bug prevents this game from being playable in any form
on the Dreamcast. There is no way to skip the opening movie
and it freezes up about 2 minutes into the movie.
* How to reproduce it: Start a new game on Dreamcast and
wait about 2 minutes.
* Can not send a save game as it happens before you have a
chance to save the game.

I wish I could be of more help to the developers, but I do not
know how to compile a version to run on dreamcast. If
somebody could link me to a daily build compiled for
dreamcast I would be happy to test this and give you any
feedback or help that I can.

comment:7 Changed 15 years ago by fingolfin

Priority: normalhigh
Summary: COMI: crash on startup movie (Monkey Island 3) - dreamcastDC/COMI: crash on startup movie

comment:8 Changed 15 years ago by fingolfin

No way to skip? So the ESC key isn't mapped on the dreamcast? Ouch

comment:9 Changed 15 years ago by zeldin

Of course it is. It's even on the soft keyboard, for those
lacking a real one, although the soft keyboard is not
available on the 0.6.x branch.

comment:10 Changed 15 years ago by zeldin

And since this is a SCUMM game, skipping the intro is of
course possible with Left mouse button + Right mouse button
(A+B on controller) as well.

comment:11 Changed 15 years ago by fingolfin

Marcus, you never commented on the actual bug, I think: Can you
reproduce it? If so, any chance to get it fixed?

comment:12 Changed 15 years ago by zeldin

There is no actual bug. During the intro, scummvm allocates
more memory than what is available on the Dreamcast (16M),
so the allocation fails and scummvm exits.

The "fix" would be to make scummvm use less memory. Should
be possible, since CoMI could run in 16MB on the PC...

(Something which might help is disabling all the engines
except the SCUMM one.)

comment:13 Changed 15 years ago by fingolfin

Did this actually get better with your recent plugin code additions to
ScummVM CVS, Marcus?

comment:14 Changed 15 years ago by SF/metafox

Yes it did, marginally. When you run it with only the scumm
engine plugin enabled, the entire startup movie is played.
It's still out-of-sync and stuttery (which is only expected
from a console that has to continually read from the disc
due to a lack of an external storage medium). The game
still isn't playable due to heavy disc reading, but this
"bug" is no longer applicable.

comment:15 Changed 15 years ago by fingolfin

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.