Opened 15 years ago

Closed 15 years ago

#1608 closed defect (fixed)

FOTAQ: Can't see or talk to the three zombies

Reported by: SF/rodneon Owned by: cyxx
Priority: normal Component: Engine: Queen
Keywords: Cc:
Game: Flight of the Amazon Queen

Description

I'm in the room with the three zombies and the
sarcophagus, but I can't see the zombies. When I try to
talk to the one on the left, the game either crashes or
the buttons at the bottom of the page flash once. I
tried getting to the same spot using a different
savegame, got the same error.

Here are the technical details you need:
- English, Talkie, Freeware version of FOTAQ.
- ScummVM v0.7.0 (April 25 daily. I had been using
the 0.6.0 release until cyx recommended the daily.)
- WinXP Pro

If anyone has a savegame just past the point where he
gets the crown out of the sarcophagus, please send it to
rodneon@yahoo.com -- I can't wait to clear this game!

Thanks,
RodNeon

Ticket imported from: #941476. Ticket imported from: bugs/1608.

Attachments (5)

queen.s06 (12.3 KB) - added by SF/rodneon 15 years ago.
Savegame
FOTAQ screenshot.jpg (27.4 KB) - added by SF/rodneon 15 years ago.
Weird error
dump.txt (5.2 KB) - added by SF/rodneon 15 years ago.
bobs.jpg (10.0 KB) - added by SF/rodneon 15 years ago.
bobs table
dump_d9.txt (151.2 KB) - added by SF/rodneon 15 years ago.
level 9 debug

Download all attachments as: .zip

Change History (17)

Changed 15 years ago by SF/rodneon

Attachment: queen.s06 added

Savegame

comment:1 Changed 15 years ago by SF/rodneon

Summary: Can't see or talk to the three zombiesFOTAQ: Can't see or talk to the three zombies

comment:2 Changed 15 years ago by cyxx

No problem for me, using the latest daily build under win2k.

Here is the screenshot taken just after loading the
savegame :
http://membres.lycos.fr/cyxdown/scummvm/fotaq/fotaq-
20040424.png. The 3 zombies are here and I was able to talk
to them and exit the room.

Right now, I have absolutely no idea what can cause this.

Changed 15 years ago by SF/rodneon

Attachment: FOTAQ screenshot.jpg added

Weird error

comment:3 Changed 15 years ago by SF/rodneon

I'm also uploading a screenshot, not that it matters all
that much... but at least you can see I'm not crazy!

comment:4 Changed 15 years ago by cyxx

Very weird... So it seems there is a problem with the
initialisation of the persons/actors.

Can you run scummvm in debuglevel 6 ("scummvm -d6 ...")
and paste the 10 last lines of output after having loaded your
savegame ? The interesting lines should begin with
Graphics::setupRoomObjects or Graphics::setupPerson.

Maybe we'll see something interesting there...

comment:5 Changed 15 years ago by cyxx

Owner: set to cyxx

comment:6 Changed 15 years ago by SF/rodneon

Here's the debug info:

Loading game from slot 6
Logic::displayRoom(50, 1, 100, 1, 0)
Display::screenMode(1, 0)
Graphics::setupRoomObjects() - Setting up person 16F, name=129
Graphics::setupPerson(2, 46) - bob = 1 name = ZOMBIE
Graphics::setupRoomObjects() - Setting up person 174, name=129
Graphics::setupPerson(7, 49) - bob = 2 name = ZOMBIE2
Graphics::setupRoomObjects() - Setting up person 175, name=129
Graphics::setupPerson(8, 53) - bob = 3 name = ZOMBIE3
Logic::setupJoeInRoom() - oldx=164, oldy=141 scale=100

I'm going to try saving the debug info up to when I try
talking to the zombie leader (the one on the left). Scumm
just crashes and the window closes instantly, but I'll try
to save the output of the debugger to a text file.

Changed 15 years ago by SF/rodneon

Attachment: dump.txt added

comment:7 Changed 15 years ago by SF/rodneon

Starting the game from a command prompt window revealed the
message given before the crash... here it is:

Assertion failed: index >= 0 && index < GAME_STATE_COUNT,
file queen/logic.cpp,
line 434

This application has requested the Runtime to terminate it
in an unusual way.
Please contact the application's support team for more
information.

Also, here's the debug info after Logic::setupJoeInRoom
(etc...):
Command::makeJoeWalkTo() - x=164 y=141 newRoom=0
Command::executeCurrentAction() - comMax=1 subj1=16F subj2=0
Command::executeCommand() - cond = 1BC, com = 16E
----- talk("zombie1.DOG") -----

That's when the games crashes. I'm uploading the full debug
dump for reference, in case you need it.

I hope this helps. I could try downloading the game again,
but it would take me days to do it on dial-up.

comment:8 Changed 15 years ago by cyxx

The assertion triggered isn't very revelant as you can't see
the zombies. So something is in a wrong state before...

Unfortunately, the debug output is exactly the same for me. I
have an idea but I am not sure... So I need your input, one
more time...

Can you turn the debug level to 9 and re-upload the output ?
(scummvm -d9 ...)

Also, once you have loaded your game, it would be nice to
dump the contents of the bobs table. To do this, hit Ctrl+d, a
green console should appear, then type "bobs" and a table will
be displayed (don't bother rewritting the table here, a
screenshot is sufficient).

I hope that, with all this information, we will be able to isolate
the bug...

Changed 15 years ago by SF/rodneon

Attachment: bobs.jpg added

bobs table

Changed 15 years ago by SF/rodneon

Attachment: dump_d9.txt added

level 9 debug

comment:9 Changed 15 years ago by SF/rodneon

The level 9 debug turned out kinda big, but here it is.

comment:10 Changed 15 years ago by cyxx

I don't see anything wrong in the debug logs... The sprite
table has the good entries too.

The problem may be related to the datafile itself. As the
majority of files related to this room are located at the end of
the resource file, I suspect a corrupted/truncated queen.1c
file. Did you encouter any errors/problems when unpacking
fotaq_talkie.zip (out of disk space for example) ?

Your queen.1c should have the following "characteristics" :
size = 54108887 bytes
crc32 = aa61d0f1
md5 = 6083b699428dd14eba0967a21335694b

comment:11 Changed 15 years ago by SF/rodneon

I got it working! The weirdest thing happened though... I
checked queen.1c for file size, perfect match. Check the
downloaded zip and the crc of the file within it... match.
So I decided to unzip the file again. Here's the weird
thing: the time info on the file I had on my HD was exactly
one hour off. The file in the zip was created or last
modified on 03/16/2004 10:27AM, the one I had was listed as
having been created at 11:27AM. Very strange, since both
files came from the same zip! I hope it's not a virus...

Thanks a million for your help. It was great fun learning a
bit more about the inner workings of the great games I've
been enjoying for years!

Let me know if I should delete this thread or remove the
uploaded files.

comment:12 Changed 15 years ago by cyxx

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.