Opened 16 years ago

Closed 15 years ago

Last modified 15 years ago

#1575 closed defect (fixed)

BS1: 'Freeze' at hospital

Reported by: SF/tsauerbeck Owned by: lavosspawn
Priority: high Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

Reproducable w/ ScummVM 0.6.0 and w/ current CVS
Language: multi-language version w/ German speech
(switching language in ScummVM doesn't described behaviour)
Platform: Linux w/ gcc 3.3.2

When you pull the plug from the floor polisher in the
hospital, the guy, his floor polisher and the mouse
cursors disappear. A few seconds later, the floor
polisher and the guy appear again, but the mouse cursor
remains hidden. Clicking anywhere doesn't do anything
and the menu can't be opened anymore either.

NOTE that this only happens when you pull the plug for
the 2nd time... When I pulled it the 1st time,
everything went alright.

In the attached savegame, I already pulled the plug
once, so just pull it again to reproduce this odd
behaviour.

SAVEGAME.INF can be found at
http://code-monkey.de/SAVEGAME.INF

Ticket imported from: #928791. Ticket imported from: bugs/1575.

Attachments (1)

SAVEGAME.000 (821 bytes ) - added by SF/tsauerbeck 16 years ago.
Savegame.000

Download all attachments as: .zip

Change History (13)

comment:1 by fingolfin, 16 years ago

Owner: set to lavosspawn
Summary: 'Freeze' at hospitalBS1: 'Freeze' at hospital

comment:2 by SF/khalek, 16 years ago

Can't reproduce this here using my english version. By the
way the hostname in the url you list doesn't resolve and in
any event you should be including SAVEGAME.000

I tested using scummvm -d0 -b31 sword1 which places you
outside the hospital.

by SF/tsauerbeck, 16 years ago

Attachment: SAVEGAME.000 added

Savegame.000

comment:3 by SF/tsauerbeck, 16 years ago

Sorry, I thought I attached Savegame.000 to the bug report,
seems like it didn't work.

Get Savegame.inf at
http://81.169.170.126/SAVEGAME.INF

comment:4 by fingolfin, 16 years ago

Priority: normalhigh

comment:5 by fingolfin, 15 years ago

What is the status of this item?

comment:6 by lavosspawn, 15 years ago

No idea, I can't reproduce it and I can't think of a possible
cause.

comment:7 by fingolfin, 15 years ago

Tilman Sauerbeck, unless you can provide some additional information
for lavosspawn, we'll have to close this as "Works for me" :-/.
Thanks for your support.

comment:8 by fingolfin, 15 years ago

Status: newpending

comment:9 by SF/tsauerbeck, 15 years ago

Sorry, I don't have any other bits of information :(
Feel free to close this bug.

comment:10 by SF/tsauerbeck, 15 years ago

Status: pendingnew

comment:11 by lavosspawn, 15 years ago

finally got my hands on an older BS1 version, so I could
reproduce it.
fixed it now.

comment:12 by lavosspawn, 15 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.