Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1574 closed defect (fixed)

FOTAQ: Crash after playing for a long time

Reported by: SF/ifo Owned by: cyxx
Priority: normal Component: Engine: Queen
Keywords: Cc:
Game: Flight of the Amazon Queen

Description

When I played FOTAQ for several hours today, suddenly
the game window disappeared leaving me on the console
with the following messages:

WARNING: Adlib: Unknown control change message 0!
WARNING: Adlib: Unknown control change message 32!
scummvm: queen/bankman.cpp:123: Queen::BobFrame*
Queen::BankManager::fetchFrame(unsigned int): Assertion
`index < MAX_FRAMES_NUMBER' failed.
Abgebrochen

"Abgebrochen" would be "Aborted" in English. The error
happened on Sloth Island after having answered the
riddle of the woman in the beginning of the second
floor when the three doors should open. After the
second one had opened, the game crashed.

The problem is that I couldn't reproduce the error, but
as the error message looked quite expressive and this
error is definitely a bug, I thought I'd post it. I
don't know when these Adlib warnings appeared, as I
played fullscreen.

ScummVM version is 0.6.0 under Linux, FOTAQ is the
download version from your site.

Ticket imported from: #928549. Ticket imported from: bugs/1574.

Change History (5)

comment:1 Changed 15 years ago by cyxx

As you said it, reproducing the error will be quite difficult. So,
I'd like to have more informations :
- which version, talkie or floppy ?
- how many hours did you played without saving before
experiencing the crash ?
- in which location/room have you started playing ?

comment:2 Changed 15 years ago by cyxx

Owner: set to cyxx

comment:3 Changed 15 years ago by SF/ifo

Oh, sorry, forgot the version: It's the talkie version.
I created the last savegame when entering the temple, which
was about 5 - 10 minutes before. The game already survived a
much longer amount of time without saving (about 45 minutes).
As far as I remember the location I have been when loading
the last savegame (and continued playing on that day) was in
Trader Bob's house.

comment:4 Changed 15 years ago by cyxx

This wasn't related to the time but to an invalid memory read.
Fixed in CVS.

comment:5 Changed 15 years ago by cyxx

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.