Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1573 closed defect (fixed)

DIG: (Italian) buggy actions description

Reported by: SF/picander Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

In the action description text (when you pass over an object) there
are no spaces between words and there never are prepositions.
i.e. (traslated to english)
instead:
"Use zero-g digger with rock"
i read
"usezero-g diggerrock"

the attach says
"usachiavescatola degli attrezzi"
but it should say
"usa chiave con scatola degli attrezzi"
Other games work

Ticket imported from: #927891. Ticket imported from: bugs/1573.

Attachments (3)

thedig.png (103.9 KB ) - added by SF/picander 16 years ago.
"usachiavescatola degli attrezzi"
dig.s00 (10.0 KB ) - added by SF/picander 16 years ago.
Savegame
LANGUAGE.BND.tar.gz (81.9 KB ) - added by SF/picander 16 years ago.
language.bnd

Download all attachments as: .zip

Change History (17)

by SF/picander, 16 years ago

Attachment: thedig.png added

"usachiavescatola degli attrezzi"

comment:1 by fingolfin, 16 years ago

Component: Engine: SCUMM
Game: The Dig

comment:2 by fingolfin, 16 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 by aquadran, 16 years ago

Owner: set to aquadran

comment:4 by aquadran, 16 years ago

this stuff is not yet finished

by SF/picander, 16 years ago

Attachment: dig.s00 added

Savegame

comment:5 by SF/picander, 16 years ago

* ScummVM version (PLEASE test the latest CVS/Daily build)
2004/04/01 CVS snapshot

* Bug details, including instructions on reproducing it
Usa an object with another always cause this problem

* Language of game (English, German, ...)
Italian

* Version of game (talkie, floppy, ...)
(don't understand this)

* Platform and Compiler (Win32, Linux, MacOS, ...)
Linux... gcc

* Attach a save game if possible
attached, but it happens from the beginning

* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.
i tried 0.60 and curent cvs. Both have the bug, if you suggest
me an older version i'll try it.

Thanks

comment:6 by fingolfin, 16 years ago

aquadran, what do you think exactly isn't "finished" here? Note that
localization in The Dig works just fine in e.g. the german version

picander, can you take the LANGUAGE.BND file of your The Dig copy,
compress it (e.g. with zip), and attach it to this report? That way, we can
analyze it and maybe find out what's the problem.

comment:7 by SF/picander, 16 years ago

Here is it!

by SF/picander, 16 years ago

Attachment: LANGUAGE.BND.tar.gz added

language.bnd

comment:8 by aquadran, 16 years ago

fingolfin: scummvm not formating translation (TODO stuff).
it need parse "%___" strings. it's used to change order
word grammar. use something <with> something. in some
languages <with> it could be in diffrent position. look at
scumm_v6.cpp "if (strstr((char *)buf_trans, "%___") != 0) {".

comment:9 by SF/picander, 16 years ago

"use A with B" is a correct syntax in Italian
it should be
"Usa A con B"

en->it
use->usa
with->con

comment:10 by fingolfin, 16 years ago

Aquadran was (I think) explaining this slightly misleading: the %___ isn't
actually used to change the order of stuff. Consider for example this
template string from your LANGUAGE.BND:
%___ %___ con %___
-> obviously, there is no way the engine could know which of the %___
is supposed to be the "first", is there?

Anyway, aquadran, I don't see any TODO comment regarding that stuff.
Hrm...

comment:11 by aquadran, 16 years ago

fingolfin:
from TODO:
"Finish formating stuff in subtitles/translation code in the
dig."
formating happen also for "hud display" in lander mini game.

for spanish translation:
from scummvm:
"usarlinternaPen Ultimate"
it should be:
"usar linterna con Pen Ultimate"
("use flashlight with Pen Ultimate")

in engine looks like:
non translated text:
"/SYSTEM.011/SYSTEM.003/Use /DIG.001/flashlight with
/LOGO.63/Pen Ultimate"
/SYSTEM.011/ -> %___ %___ con %___
/SYSTEM.003/ -> usar
/DIG.001/ -> linterna
/LOGO.63/ -> Pen Ultimate
it's possible to change order word "con" by put in differnt
position i think.

from lander game:
"Vel Y: %___ cm/s"
"/LANDER.007/Y Vel 1965 cm/s"

comment:12 by fingolfin, 16 years ago

Owner: changed from aquadran to fingolfin
Resolution: fixed
Status: newclosed

comment:13 by fingolfin, 16 years ago

I implemented %___ support in CVS (a cleaned up version will follow
soon, too).

Aquadran: yes you can insert/remove text in the translations - but you
can't really change the word order of the *variable* parts with the
systems LucasArts used there.
E.g. assume the first text to insert is "Foo" and the second text is "Bar".
Then you can use "%___ hits %___" to produce "Foo hits Bar". But it is
impossible to get "Bar hits Foo". This is a serious limitation when
translating, since word order can be different for different languages.

In any case, that's not our problem; just a limitation of the system
LucasArts implemented there :-)

comment:14 by SF/picander, 16 years ago

> I implemented %___ support in CVS

I just downloaded CVS and compiled it. It seems this problem is still
there.

Note: See TracTickets for help on using tickets.