Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1572 closed defect (invalid)

MI: melee island crash

Reported by: SF/sevenveils Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

it's a bummer everyone seems to think secret of monkey
island (cd version) is "playable." it's most definitely not.

i'm using the 3/15 version of the windows installer of
0.6.0 (since i "dont know what i'm doing") to try and
play the cd-rom and having passed the archway into the
part of melee island with the store, alley, church, jail,
etc., i cannot pass back into the section with the map-
selling pirate and voodoo store without getting the
following error:

error: (DCXE) not found in 0... illegal block len -
1685021081

this is the english version, this machine is running
win98. i'm attaching a saved game from right near the
archway in question. thanks to anyone out there who
can fix this mutha....i'm desperate to play this #^@#
game!

*j

Ticket imported from: #927340. Ticket imported from: bugs/1572.

Attachments (1)

monkey.s03 (9.1 KB) - added by SF/sevenveils 15 years ago.
saved game (guybrush standing next to arch that causes crash)

Download all attachments as: .zip

Change History (12)

Changed 15 years ago by SF/sevenveils

Attachment: monkey.s03 added

saved game (guybrush standing next to arch that causes crash)

comment:1 Changed 15 years ago by fingolfin

Sounds like your data files might be broken...

Anyway, it's not clear to me which precise Monkey Island version you are
using: an english PC version? And "CD" version, do you mean you have
the version which comes with digital audio tracks; or does it use midi
music?
What is the md5 checksum of your monkey.000 and monkey.001 files?

comment:2 Changed 15 years ago by SF/sevenveils

Thanks for the reply....sorry about the vagueness.....

This is the original multi-language PC CD-ROM release with
digital audio (purchased like a sucka on Ebay), with no
scratches on the disc, so I wouldn't expect the data files
would be broken. ? If so, I guess I'm *really* screwed!

At work now; I'll check the md5 on the files when I'm home.
Thanks much for any help--based on other posts, I'm
definitely in a bit over my head compared with you folks.

comment:3 Changed 15 years ago by SF/sevenveils

ok....
checksum for monkey.000 (straight from the cd-rom) is:
2D1E891FE52DF707C30185E52C50CD92

for monkey.001:
D074150DE681D49FF350E8AD60EE4ABD

this unfortunately means nothing to me. am i hosed?

many thanks
*j

comment:4 Changed 15 years ago by eriktorbjorn

That's the same checksums as the version I have (english CD
version), unless I'm looking at it cross-eyed. Are you
playing the game from the CD, or did you copy the data files
to hard disk? Supposedly (according to the README) Windows
has trouble with games that want to both read data and play
music from the CD at the same time, so copying the data
files to hard disk may help.

Though I haven't heard of that problem causing a crash at
that particular point before. Usually it's been something
like "the game crashes when I enter the SCUMM Bar"...

comment:5 Changed 15 years ago by fingolfin

Does that mean you can't reproduce the crash, erik, or just that you
didn't have a chance to try the savegame yet?

comment:6 Changed 15 years ago by eriktorbjorn

To be honest, I didn't even notice the attached savegame. It
was early in the morning, and I plead incompetence. :-)

I've tried the savegame, both with 0.6.0 and the latest CVS
snapshot, and I could back and forth through that archway
until I got bored without any ill effects. It's not quite
the same test case as described in the bug report, though:

* I used Windows XP, not 98.
* I've copied the data files to hard disk and ripped the
music. (The CD is with my Linux box, so I can't try playing
from it - not right now, at least.)

comment:7 Changed 15 years ago by fingolfin

Summary: monkey island 1 melee island crashMI: melee island crash

comment:8 Changed 15 years ago by fingolfin

To quote our REDAME:

All CD games:
- If you are experiencing random crashes, and your game plays music
from CD, you have encountered a Windows bug. Try copying the data
files from CD to your hard disk, and running them from there.

comment:9 Changed 15 years ago by fingolfin

Owner: set to eriktorbjorn
Resolution: invalid
Status: newclosed

comment:10 Changed 15 years ago by eriktorbjorn

Actually, I still don't know if sevenveils was playing from
CD or hard disk. That's why I asked that question early on,
but I never saw any answer to it. (Though the "straight from
the cd-rom" bit indicates that he may have been.)

comment:11 Changed 15 years ago by SF/sevenveils

i followed erik's advice and copied the files to HD (the music
has never worked, but that's a whole other story), and have
been playing straight from Windows without Scumm, and have
had far fewer problems...i think it's only crashed once, and
not for a couple days. it must've been trying to play from CD
while the (nonexistent) music was making its way through too
that was crashing.
thanks guys!

Note: See TracTickets for help on using tickets.