Opened 16 years ago

Closed 16 years ago

Last modified 13 months ago

#1567 closed defect (duplicate)

scummvm is not 64-bit clean

Reported by: SF/duraid Owned by: SF/ender
Priority: normal Component: Ports
Keywords: Cc:
Game:

Description

On an LP64 system, numerous games will crash at
costume.cpp:469

*dst = pcolor;

at that point, dst will have a value that looks "like"
a pointer, but is not a valid one.

Easiest way to reproduce this one:

1) get a 64-bit system (e.g. x86-64, ia64, ppc64)
2) play sam and max: all you have to do is go
downstairs (outside the building) and walk left (or
indeed, just walk around)
3) observe the segfault

May I humbly suggest that the scummvm developers do not
assume this is a toolchain bug. This bug can be seen on
at least the three platforms mentioned above, using a
whole range of different compilers. The problem is
scummvm. ;)

Ticket imported from: #924337. Ticket imported from: bugs/1567.

Change History (3)

comment:1 by SF/ender, 16 years ago

Duplicate of bug #880814. Closing.

comment:2 by SF/ender, 16 years ago

Owner: set to SF/ender
Resolution: duplicate
Status: newclosed

comment:3 by digitall, 13 months ago

Component: --Unset--Ports
Note: See TracTickets for help on using tickets.