Opened 16 years ago

Closed 16 years ago

#1534 closed defect (fixed)

MI2: Floating Point Exception

Reported by: SF/f0xino Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

Version scummvm-20040315
Italian Version

Phatt Island
Scumm quits with this line
Fatal signal: Floating Point Exception (SDL Parachute
Deployed)

Ticket imported from: #916886. Ticket imported from: bugs/1534.

Attachments (1)

monkey2.s03 (12.1 KB ) - added by SF/f0xino 16 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 by SF/f0xino, 16 years ago

Summary: Floating Point ExceptionMI2: Floating Point Exception

by SF/f0xino, 16 years ago

Attachment: monkey2.s03 added

comment:2 by fingolfin, 16 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 by SF/f0xino, 16 years ago

Scumm quits (Fatal signal: Floating Point Exception (SDL
Parachute Deployed)) when Guybrush is arrested on Phatt
Island and the fat man starts to talk.
sorry for my bad english :)

My ScummVM version: ScummVM 0.5.7cvs (Mar 15 2004 03:48:24)
Language of game: Italian
Version of game: PC/Floppy
Platform: Linux

comment:4 by SF/f0xino, 16 years ago

No problem if i use Music Driver: No Music
For the bug report i use Music Driver: Default

comment:5 by fingolfin, 16 years ago

Sadly I don't own the italian version of MI2, so I can't use that
savegame.

Some more details on your setup would be nice, in particular, please try
with the regular 0.6.0 release, instead of 0.5.7 (although at this point it
might be too late, you may have savegames which won't work with
0.6.0); and also tell use details about your machine, i.e. what kind of
processor / speed (just in case...(

I don't know if you made alterations to your config file, but if not, then
the default music driver is the "adlib" driver.

comment:6 by eriktorbjorn, 16 years ago

It appears to have been caused by the recent random number
generator change to adlib.cpp - calling getRandomNumber(-1)
causes ScummVM to crash, while calling the old random_nr(-1)
doesn't. I've changed back to the old RNG until we know more.

Fortunately it appears the change was only made on the trunk
- 0.6.0 should be fine.

comment:7 by fingolfin, 16 years ago

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:8 by fingolfin, 16 years ago

Fine. I don't think there is any particular need for us to use
getRandomNumber in the adlib code. In fact the precise emulation might
rely on the correct random number function (as this problem partially
showed :-)
Thanks, Erik!

Note: See TracTickets for help on using tickets.