Opened 15 years ago

Closed 15 years ago

#1531 closed defect (fixed)

COMI: vanHelgen's head overlaps his text

Reported by: SF/wooshell Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

When talking to vanHelgen in the barber shop, sometimes
his head overlaps a part of his text with today's
0.5.7cvs snapshot on Solaris/sparc.
www.beissmich.de/comibug.jpg contains a snap of the scene.

Ticket imported from: #915586. Ticket imported from: bugs/1531.

Change History (5)

comment:1 Changed 15 years ago by fingolfin

Summary: vanHelgen's head overlaps his textCOMI: vanHelgen's head overlaps his text

comment:2 Changed 15 years ago by fingolfin

Please attach relevant files to the bug report (like save games and
screenshots), instead of posting them to external sites. Thanks!

comment:3 Changed 15 years ago by sev-

This reminds me FT bug #885466 (Text gets drawn under moving
bits). Maybe it's same bug.

comment:4 Changed 15 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:5 Changed 15 years ago by fingolfin

Fixed in CVS. The problem was caused by text being position at x
coordinate 0; this was then changed to coordinate -1 by the NUT
renderer, which is a special valued used in other parts of the code as a
flag... booom.

The issue is *not* related to FT bug #885466.

Note: See TracTickets for help on using tickets.