Opened 16 years ago

Closed 16 years ago

#1498 closed defect (fixed)

MI3: crashed after the 3rd cannon shot

Reported by: SF/vampier Owned by: aquadran
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

Yep the one at the beginning.

version 6.0.0 pre

Curse of Monkey Island

Error code given back:

error 9:2019: 0xFAE8: ImuseDigiSndMgr::openSound()
Can't alloc free sound slot.

All settings on standard, using the win32 version.

Ticket imported from: #904664. Ticket imported from: bugs/1498.

Change History (3)

comment:1 by eriktorbjorn, 16 years ago

I can't reproduce this myself, but I'm not familiar with
this part of the code. Sounds like a job for aquadran...

The only place I can see where it would leak sound slots is
at the end of ImuseDigiSndMgr::openSound(), if the function
returns NULL. But does that ever happen? Of course, if the
game scripts insist on opening sounds faster than they're
being closed, we will run into problems...

It does strike me as a bit inconsistent that "All slots are
full" (which I do get) is just a warning, while "Can't alloc
free sound slot" is an error.

comment:2 by eriktorbjorn, 16 years ago

Owner: set to aquadran

comment:3 by aquadran, 16 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.