Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1497 closed defect (worksforme)

COMI: Asynchronization in Attacking Fort cutscene

Reported by: SF/bigmuzzy Owned by: aquadran
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

(Well, I've reported this bug already in Forum)

Tech info: CoMI english; Windows XP; ScummVM
0.6.0pre

I launched the game (Mega Monkey) and watched intro
without interruption. Sound goes afore animation at the
very time as "conversation" between LeChuck and Elaine
starts. (i.e. LeChuck cries "Fire!" and 1-2 sec. later
opens his mouth. And so on.)
I've seen this 3 times.

When run CoMI without ScummVM everything is OK.

Ticket imported from: #904201. Ticket imported from: bugs/1497.

Change History (13)

comment:1 Changed 15 years ago by SF/bigmuzzy

Summary: Asynchronization in "Attacing Fort" cutsceneCOMI: Asynchronization in Attacking Fort cutscene

comment:2 Changed 15 years ago by eriktorbjorn

Do you play the cutscene files from the CD or from hard
disk? I don't know if it makes a difference - I don't have
my CDs here to test it with - but it's the only theory I
have at the moment.

comment:3 Changed 15 years ago by SF/bigmuzzy

I play cutscenes from CD.

comment:4 Changed 15 years ago by eriktorbjorn

Does it make any difference if you copy them to hard disk?
Maybe the syncing code is ok - it works for me - but the
code that reads the cutscene data is sub-optimal.

comment:5 Changed 15 years ago by SF/kelmer

I've tried copying them to hard disk and the asynchronization
occurs anyway.

comment:6 Changed 15 years ago by SF/bigmuzzy

I've copied first CD on hard drive and launched CoMI from
there. The same effect.

Now I can tell you more. As you know, intro in CoMI can be
virtually divided on several parts: first, when Guybrush
writes "captain's log"; second, the captions; third, the fort
attack; etc. There are no lips movements in first part,
therefore it could be difficult to say about synchronization
there. Much less can we say about captions' part. But in the
third part (a)synchronization is easy to see.
So I've launched the game without ScummVM and watched
intro more carefully. And I'm sure now that sound (in
ScummVM-CoMI) runs forward in *first* part already. (In the
end of first part, there is cannon fire that attracted Guybrush
attention. In ScummVM-CoMI Guybrush reaction is about
one second longer.) I think sound is just playing slightly
faster from very beginning and distance between sound and
animation is growing more and more.

I'll try to check this on another computer tomorrow (Windows
XP also).

comment:7 Changed 15 years ago by fingolfin

Sounds like either an iMuseDigital, or a SMUSH issues... aquadran?

comment:8 Changed 15 years ago by fingolfin

Owner: set to aquadran

comment:9 Changed 15 years ago by SF/bigmuzzy

I've tried CoMI on another computer. And from CD. Funny,
but synchronization was absolutely OK there (both 0.5.1 and
0.6.0pre). Think, hardware on both computers more or less
equal. At least, processor frequency and quantity (...or
should I say "amount"?) of RAM...

Could the problem be in sound/video card? Or in Windows XP
version (there is Service Pack 1 installed on second
computer, and as far as I remember there is no Pack on first)?

comment:10 Changed 15 years ago by aquadran

i can't reproduce this. the one second delay after cannon
fire is also in original engine.

comment:11 Changed 15 years ago by SF/bigmuzzy

aquadran> the one second delay after cannon fire is also in
original engine.

I meant delay in ScummVM-CoMI is about one second longer
than in original engine on my home computer. Though on my
work computer they are equal.

Besides, when I say "sound is playing slightly faster", I mean
that it's playing faster than animation, not than sound in
original engine ;)
So it could be that animation in ScummVM-CoMI is slower
than in or.engine. Or both sound and animation are
faster/slower. Think I should better try to measure time...

[By the way, I am trying to download and install all Windows
updates at home, but it could take some time. I've installed
two graphic-related patches (one for Windows and another
for nVidia products) already, but they didn't help.]

comment:12 Changed 15 years ago by SF/ender

I would say it's your soundcard. If it's an old generic model, then
I wouldn't be suprised.

I'm closing this bug as machine-specific.

comment:13 Changed 15 years ago by SF/ender

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.